Audio spectrum visualizer becomes very laggy after exporting

I’m trying to make a simple video with a background image, some text and an audio spectrum visualizer at the corner. The problem is that in the editing space the spectrum seems to work fine (a little choppy but that’s usual behaviour with the playback itself not just the visualizer), but after exporting it lags a lot, to a point where it’s not even usable

I have a win10, 8gb ram, Intel(R) Core™ i7-3770 CPU @ 3.40GHz processor and a gt420 gpu

Project file is attached

Purple.mlt (12.1 KB)

Hi @MonnoCatto
I used your attached project and copied all your filters to my own files.


After exporting, the result looks fine on my computer:

Thank you for your time in trying, what export settings did you use?
I later figured out if I used certain export settings (mostly lossless) it turns out fine, but I just can’t expend all the gb it takes to store them like this (for context, I exported with the youtube preset but with fps set to 60 when it came out lagging)

I used the default export settings



Using the YouTube preset gives me the same result (No lagging)

I get an error with this encoder

[producer avformat] audio: total_streams 1 max_stream 0 total_channels 2 max_channels 2

[AVIOContext @ 00000201ceacac00] Statistics: 131072 bytes read, 2 seeks

[filter swresample] 2(stereo) float 44100Hz → 2(stereo) float 48000Hz

[h264_nvenc @ 00000201cfaf8000] Cannot load nvEncodeAPI64.dll

[h264_nvenc @ 00000201cfaf8000] The minimum required Nvidia driver for nvenc is 390.77 or newer

[h264_nvenc @ 00000201cfaf8000] Nvenc unloaded

Failed with exit code -1073741819

Failed with exit code -1073741819

but then I tried the “default codec for the format” option and it exported fine with no issues

apparently my ancient gpu is just not compatible with certain codecs (including the one I was using previously)

thank you for your help

1 Like

I recommend you turn off the checkbox for hardware encoder in export as it is clearly not working on your system.

I couldn’t turn it on if I wanted to, shotcut gives me an error message if I try and disables it immediately

I see how the screenshots mislead you to change Advanced Codec settings. Most users should use a preset or change nothing and avoid turning on Advanced.

I had to change the codec because the default one was causing problems with my gpu, but I understand what you mean

This topic was automatically closed after 90 days. New replies are no longer allowed.