Audio channel monitoring - CH1 Left. CH2 Right


#1

Hello,

I intend to use Shotcut for quality control, just opening the video for playback. The video is displayed on a Sony SDI monitor via a blackmagic decklink card. Is there a way to select CH1 for the left and CH2 for the right side of the headphones/speakers?
I can only select one channels in the properties - audio tab, and it’s mixed to both the left/right side as mono.
The source contains 8 channels, but the first two is treated as LEFT-RIGHT, and I want to monitor them simultaneously.


#2

I just tried a test with an 8-channel file. Using my headphones plugged into my computer, I observe exactly the behavior you request: CH1 is in the left and CH2 is in the right. CH3-CH8 are ignored.

I would suggest that you turn on the “Audio Peak Meter” in Shotcut and observe whether the left and right meters are changing independently. The are for me.

Also, maybe double-check that your speaker/headphone setup provides stereo separation from other applications. For example, play some files from here and see if you hear the L/R separation:
https://www2.iis.fraunhofer.de/AAC/multichannel.html

If none of that helps you, the next step would be for you to post a screenshot of the “Audio” tab from the “Properties” panel for your clip in Shotcut so that I can see exactly what kind of audio you have to reproduce your problem.


#3

Thanks for your fast reply,
to clarify things I made a screencast: https://youtu.be/CW2v-xqYlfw
I tested an audio file from the link you provided (downloaded, opened in Shotcut) - it works perfectly, as I need.
However the tested files produces this problem. it’s an.mxf from a sony X400 camera - you can see the details in the video.


#4

Thanks for the video. I now see the difference between our files. The file I was testing has 1 audio program with 8 channels. Your file has 8 audio programs with 1 channel each. It seems like a minor difference, but right now Shotcut is designed to only operate on one audio program at a time.

I’ll have to do some thinking to see if there is a way to better support this file.

In the meantime, one workaround would be something like this:

  1. Create two tracks in the timeline
  2. Drag the file to both tracks and align them both to the beginning of the timeline.
  3. Click on the clip in track 1 and choose the first audio program in the properties panel
  4. Apply the balance filter to the clip and set the balance all the way to “left”
  5. Click on the clip in track 2 and choose the second audio program in the properties panel
  6. Apply the balance filter to the clip and set the balance all the way to “right”

I understand this is a very inconvenient workflow. But it’s the best I can come up with given the current design.


#5

I see, thanks for the solution!
Looking forward for the next versions.


#6

I think I have an idea of how to modify Shotcut to work with your file. But i need a way to test it. Would you be willing to share a sample file with me so that I can try it?


#7

@Alma I found a way to create my own file that matches yours. I have made a change in Shotcut that will allow you to choose “All” audio tracks in the clip properties. This change will be in the next release.


#8

Sorry, I was away in the weekend, but I will send you a test file Monday afternoon. Thanks for the fast action! Is there a way to “buy” you a beer/coffee? :slight_smile:


#9

No need to submit a test file. I was able to make my own.

We don’t really have a way to accept donations. The best way to show appreciation would be:

  • Test and report back the results after the next release
  • Help other people on the forum
  • Disable your adblocker for *.shotcut.org domains