Audio bug after playing external audio

Hi,
I’ve been using Shotcut for a while, and I’ve come across a really annoying bug.
If I play audio from another source besides Shotcut, like Youtube or any music player, the audio in the timeline is muted until I restart Shotcut. Closing whatever was playing the audio doesn’t fix it.
The weird thing is that if I play a clip from the playlist, the audio is fine.

You should report your operating system and it’s version and Shotcut version. I don’t think I experiencedb this anywhere except macOS a while ago and haven’t heard about it in a long while.

Hi Tians and welcome to the SC forum.

Not sure what OS you are using, but had a similar problem a while back under Win 7.
The solution was to install the latest audio drivers and in the audio settings, make sure that the option “Let xxxx take exclusive control…”, is not enabled.
Where xxxx is the name of the application, in this case Shotcut.

I’m using Windows 10 with shotcut version 19.06.15, and I’ve already installed the latest audio drivers.
As far as I could tell, there weren’t any audio settings in Windows 10 like the one you said to change.

See here:

https://audible.custhelp.com/app/answers/detail/a_id/9463/~/how-do-i-turn-off-exclusive-mode-for-a-windows-audio-playback-device%3F

I don’t use Win 10 so can’t say for sure if it still applies.

I also tested this quite a bit on Windows 10 but did not reproduce it.