Annoying "qmelt quit unexpectedly" on macOS (real crash?)

I been using Shotcut for many years (since MacOS 10.7.11; at present I’m using Shotcut 20.06.28 with MacOS 10.10.5 on an Intel iMac 21.5 inch, Mid 2011, 2.5 GHz Intel Core i5, 16 GB in RAM and more than 300 GB always free on my working hard disk). I even needed to re-learn its use when the starting interface changed. But it’s so useful and powerful that any effort to learn after every update is worth it. I’ve processed hundreds of videos with Shotcut since the very first time, mainly mp4. Of course, I use Shotcut to resize, enhance (using 2 or more filters) and edit my video files.

This last days I have had a very strange crash with Shotcut. Suddenly I received the not very welcomed “qmelt quit unexpectedly” message. I guessed that it should be a crash, because I was presented with the “Click Reopen…” window on the very known crash report on macOS. If I chose to “Ignore”, the encoding process continue, but the final file is NOT a video file, but an audio one -???-, that has a very small weight compared with the expected one for the video output. The same occurs if I click on the “Reopen” button. Thus, from here it appears that process is not stopped but strongly affected, even if qmelt quit unexpectedly. Strange, very strange.

After reading the Shotcut FAQ. I found that on Windows it’s suggested to “delete your Shotcut registry entries and try again. The registry keys are stored at HKEY_CURRENT_USER\Software\Meltytech\Shotcut”. To make things still better, I deleted Shotcut application, its preferences file and the entire Meltytech folder located at ~user\my account\Library\Application Support. Thus no traces at all of Shotcut on my computer. Then, I reinstalled Shotcut again from its original .dmg file. However, even with this completely new and fresh installation, the crash report came again.

This problem persist no matter what kind of mp4 file I try since to process, not only for the file that gave me the first crash report. This crash report appears always some time after the second pass of process has started (I always use a process with “Average Bitrate” fixed to my needs and “Dual pass” to enhance rendering).

To make things more weird, just before to submit this case, I chose the third option on the crash window: “Report…”, to see more detailed information and, if wanted to send a report to Apple (I didn’t send any report to Apple). I’m attaching to this the very long report (as they always are) if this could be of some help (I’ve copied and pasted on a text file, because there is no option to export on the Apple report window). It’s de “Shotcut crash report from Apple.txt” text attached just below. I’ve waited until the encoding process finished and, amazingly this time I finished with my mp4 file correctly encoded! What the hell! If I chose “Ignore” or “Reopen” process fails, but now, choosing “Report…” I’ve got my file correctly encoded?

Shotcut crash report from Apple.txt (70.5 KB)

Since the video was too long (about two hours), I’ve closed Shotcut and tried with another shorter video (in order to get it finished quick). Usually I chose “Custom” as a project, because I need to adapt to the current dimensions of the video (not always with standard dimensions). This time I chosen simply “Automatic” to make things direct from Shotcut. I even not touched anything on “Advanced”, as I usually do to adjust to my needs. All gone well. As a second exercise, now, I tried by applying some of the advanced options to suit closer those of the original video, like changing “Interpolation” to “Hyper/Lanczos (best)”, using “Average Bitrate” as “Rate Control” (and selecting anything closer to the original), ticking “Dual pass”, and changing the audio “Bitrate” to anything closer to the original. Again it was finished with no problem, but I’ve ended with a “movie2.mp4_2pass.log.mbtree” file also that weights even more than the encoded file. Finally, as a third exercise, I’ve added a couple of filters (“Hue/Ligthness/Saturation” and “Contrast”) and repeated the encoding. All went fine (this time with no “movie2.mp4_2pass.log.mbtree” file present at the end).

I accept that I don’t understand anything. Why I was getting the crash reports just before with my previous videos and now crash is not present? Why on the “Advanced”, but with no Filters process I ended up with the “movie2.mp4_2pass.log.mbtree” file that usually disappears after the encoding process is finished? What has been causing my recent crashes with all previous videos, even completely deleting Shotcut and all its associated files and reinstalling it again? Does anyone have any ideas?

Reading the pinned “Export failed - Find solutions” thread, I found that its suggested to get the Job Log to help understanding what’s happening. Ok, I’m attaching a copy of the last encoding (the one that I described on the previous paragraph). It’s de “Job Log.txt” text attached.

Job Log.txt (6.6 KB)

At the very beginning I read something strange:

“mlt_repository_init: failed to dlopen /Applications/-Video Utilities/
(dlopen(/Applications/-Video Utilities/, 2): Symbol not found: _clock_getres
Referenced from: /Applications/-Video Utilities/…/Frameworks/libgomp.1.dylib
Expected in: /usr/lib/libSystem.B.dylib
in /Applications/-Video Utilities/…/Frameworks/libgomp.1.dylib)”

Then, if I understand well when opening Shotcut there is a problem? Something INSIDE the app is failing? Sorry? This is a fresh installation from the ORIGINAL downloaded here (not on a external site) that has NEVER had a problem. Thus… “failed to dlopen” with something missing? I did not compiled anything, I’ve got the installing file from the Shotcut webpage! Of course, this “missing” was present since the first installation and Shotcut always worked fine. Is this “missing” at the origin of the very weird results I’ve got this last days (unreliable encodings that can finish unexpectedly with or without a video file)? According to what is said in the “Export failed - Find solutions” thread, when there is a failure, we also have a “failed” report in the Job window; I don’t have it, I just have the message “qmelt quit unexpectedly”. So mine is a crash, not an export error. Is that problem at the opening of Shotcut who is at the origin of that crash? I am truly confused.

Any opinion/help is welcomed

Any special reason why you a using a 3-years old version of shotcut, Shotcut contains a lot of special libs, there can be broken by OS updates.

[quote=“TimLau, post:2, topic:39051, full:true”]
Any special reason why you a using a 3-years old version of shotcut…[/quote]

As you can read at the very beginning of my message…

“…at present I’m using Shotcut 20.06.28 with MacOS 10.10.5 on an Intel iMac 21.5 inch, Mid 2011, 2.5 GHz Intel Core i5, 16 GB in RAM and more than 300 GB always free on my working hard disk…”

This is the last version of Shotcut that’s supported by MacOS 10.10.5.

But the PROBLEM is not there. As you can read, ALL was going perfectly and suddenly… what you can read. A “crash” that is not a CRASH, but seems to be a crash. Yeah, as weird as it can sounds. For that reason I’ve submitted the crash report from Apple (there this problem is identified as a crash). I hope that anyone could find what happened accordingly to the reports (Apple and Shotcut) I have attached. My knowledge on this kind of technical problems is not very good.