A problem with multi-audio-track videos

Windows 10, latest upates, shotcut latest version as of this post, I always update as soon as the update comes out.

So this has been a problem for me over many versions of shotcut now.

Every time I record a multiple-audio-channel video on the most common programs such as OBS or nvidia replay, shotcut doesn’t recognize the file as “seekable” and requires it be reformatted into a HUGE file with the audio usually being weirdly corrupted :frowning:

Can you please have a look at that?
I believe you can EASILY replicate it by just recording a multiple-audio file using Nvidia Instant Replay, using Geforce Experience, and trying to edit it in shotcut.

Can it please be made … er, recognized better by the program?

Much love and kudos for your amazing work.

1 Like

A great reason not to use Nvidia Geforce. OBS is cleaner to use. I always shut down Geforce before recording with OBS. I have always had major problems with audio from Geforce. Geforce Experience even screws up my sounds on various games until I shut it down. At least this has been my experience with Geforce.

That’s not an answer or helpful.

Nvidia has a feature that captures the last 10 minutes of gameplay in case something cool happened. OBS has no such feature. Yet even with OBS when I record multi-audio the file is still unseekable by shotcut (and seekable if I use the exact same settings, except one audio channel).
So clearly there’s something going on.

Not to mention instant-replay is EXTREMELY widely adopted. Probably used by significantly more people than use shotcut even. It’s a very good program.

With Geforce I always get a variable frame rate.
With Geforce I always get audio sync issues.
MediaInfo_2022-07-11_21-35-00

MediaInfo_2022-07-11_21-35-44

With OBS I always get a constant frame rate.
With OBS I have no audio sync issues.
MediaInfo_2022-07-11_21-36-33

Just offering my experiences with both of the software you mentioned.

I’m not debating the usefulness of the software, just the way it produces the video file. Variable frame rate video many times is not seekable. Many cell phones also have variable frame rate and not seekable.

I can’t duplicate this issue.

OBS using:

SSD Drive
Rate: VBR
x264 Encoder
2 audio track
bitrate 5050 Kbps
CRF 23
Keyframe 0
1920x1080 30fps

Shotcut Video Mode: 1920x1080 30fps.
shotcut_2022-07-11_22-04-14
Shotcut 22.06.23

Using GeForce Experience at 30 FPS
shotcut_2022-07-11_22-06-49

Will you stop replying please.
You’re confusing the issue, which is very clear in the first post.
Shotcut cannot handle multi-audio-channel files from nvidia instant replay.
Now if this can be fixed, great, if not, then no.
These files work just fine with other editing programs, but I would be very happy if it was fixed in shotcut

What you’re doing is like like if my mazda had an issue you’d go out of your way to say “my ford hasn’t had this issue”, and then spend 3 posts discussing it, which is irrelevant to the issue.

1 Like

If Shotcut is prompting you to convert the files, then Shotcut probably can not be made to work better with the files. OBS can be configured to generate compatible files. Maybe you would be willing to try to change some OBS settings.

Hudson made a post demonstrating that OBS can be used to generate multichannel files that work in Shotcut without conversion. He also demonstrated that the NVidia program always generates variable framerate files - which must be converted. So I found his posts very helpful.

Maybe someone can offer some instructions of how to configure OBS to create constant frame rate files.

See here:

in particular the post which mentions MULTI-TRACK AUDIO and says:

Normally issues in Premiere come from people ignoring the DO NOT RECORD TO MP4 warning that pops up whenever it’s selected.
It’s there for a reason .
Premiere hates the mp4 files that OBS creates. Most video editing suites do.
Record to MKV if you need multi-track audio, or FLV if you do not. Then REMUX to MP4 from OBS’ File menu, Remux Recordings. It takes seconds, and Premiere actually works nicely with remuxed mp4 files.

What is the exact message? There are separate technical things and associated messages: not seekable and variable frame rate being unreliable. I think this thread is confusing the two at times. If it says it is not seekable then the FFmpeg library API is returning an error when we made a seek test upon opening the file.

I don’t think I can choose file type in Instant Replay. OBS is not part of the discussion or the problem

Yes, it works just fine if I convert the files (but only on the highest settings, otherwise it’s corrupted.

The problem is that this turns a 1gig file to a 50gig file

That is helpful to focus the conversation. I think people may have been confused by this previous statement:

If your question is limited to Nvidia Replay, then the answer seems to be that the files are always variable framerate and will always need to be converted. I do not volunteer to install Replay. But if you want to send me a link to a file that you have trouble with, I am willing to download it and examine it.