A MP3-File is shorter in Audio-Track than it actually is

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)?

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

I have exported a MP3-File with shotcut which is 2:45 Minutes long. And if I import this file into another Video Project in Shotcut this Audio-File is only 01:22 Minutes long. Where is the rest of the file?

The original Audio-File:

And the “cut” Audio-File directly after importing and without editing:

I CAN in fact "fix this by setting the exact length of the Audio-File in the Audio-Tab of the Track then it seems to work fine but only after this “fix” and Wave-Visuals are not calculated for this one. And this feels a bit like hacking and I dont know how “safe” this is.

I tried to reproduce this. But I am not able. Here are my steps:

  1. Open a video file that is longer than 2:45
  2. Drag the file to the timeline
  3. Trim the file to 2:45:00
  4. Open the Export panel, choose the audio->WAV preset, and export
  5. Close the project and make a new project
  6. Open the exported WAV file
  7. Drag the wav file to the timeline
  8. Observe that the opened file is 2:45 and the waveform displays for the whole file

Maybe there is a detail that I am missing to cause the problem. Can anyone else recreate the issue?

I couldn’t reproduce either.
We see that @Snickbrack used at least two file format for his exported file. So I used 3 clips of different formats myself (MP3. MKV and FLAC)

30 seconds before exporting.
30 seconds after importing in another project.

So I finally found some time to prepare something.

Just a simple track: CJ - Whoopty

Imported into Shotcut:

Then Exported:

Re-Import into a new fresh Shotcut Project:

I have also attached the test.mp3-File here (Sadly the mp3-Extension is not allowed here so its a Zip now):
test.zip (4.1 MB)

I can set the exact time of the MP3-File to the one in the new fresh project and its finely usable but now looks like this:

I have used these exporting settings to export to MP3:

I reproduce in 384k with the mp3_mf codec you have selected.
Use the libmp3lame codec suggested when you select export to mp3.
The parameters of the 2 files show: Output bitrate 320Kbits/s.

1 Like

Okay thanks.

Can verify that with the “…lame”-Codec it works fine!

This topic was automatically closed after 84 days. New replies are no longer allowed.