8 hours to export only 30-min video with ver.0501!

Hello! Been using this program for nearly two years with no serious problems.

B.U.T. :(((((

Installed the latest version 0501 yesterday and now it takes 8-9 hours to export about 30-min mp4 video that weighs under 500MB!! What in the world is happening?!?

Like I said, I’ve never had such a problem since I started using shotcut for a couple of years and my operating system is quite new (i3, Windows 10, 8G ram, SSD and all that jazz).
It is just a normal video for youtube. I can’t do anything with this speed. :((
I even uninstalled this latest version and re-installed the 0321 version. The same.
Other than this issue, everything is fine with this program! It’s the same-format video I have been editing for years.

Plz help. This is the easiest and the most convenient video editor on the planet.
I’m adding the log message just in case below. Thanks for your help in advance!!

plugin_mgr_get_object_file_plugins: error opening shared object file ‘D:\Program Files\Shotcut\lib\ladspa/AUTHORS’: “D:\Program Files\Shotcut\lib\ladspa\AUTHORS”: ������ ������ ã�� �� �����ϴ�.
plugin_mgr_get_object_file_plugins: error opening shared object file ‘D:\Program Files\Shotcut\lib\ladspa/COPYING’: “D:\Program Files\Shotcut\lib\ladspa\COPYING”: ������ ������ ã�� �� �����ϴ�.
plugin_mgr_get_object_file_plugins: error opening shared object file ‘D:\Program Files\Shotcut\lib\ladspa/readme.txt’: “D:\Program Files\Shotcut\lib\ladspa\readme.txt”:
[libx264 @ 000002326ab9e880] using SAR=1/1
[libx264 @ 000002326ab9e880] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
[libx264 @ 000002326ab9e880] profile High, level 4.2, 4:2:0, 8-bit
[libx264 @ 000002326ab9e880] 264 - core 159 r2991M 1771b55 - H.264/MPEG-4 AVC codec - Copyleft 2003-2019 - http://www.videolan.org/x264.html - options: cabac=1 ref=2 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=6 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=6 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=1 keyint=300 keyint_min=30 scenecut=40 intra_refresh=0 rc_lookahead=30 rc=crf mbtree=1 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2
[AVIOContext @ 000002326aadfc00] Statistics: 192872 bytes read, 3 seeks
[producer avformat-novalidate] D:/Shotcut/myfile/file.mkv
missing hwaccel parameters. skipping hardware initialization
[libvpx-vp9 @ 000002327295ca00] v1.9.0
[libvpx-vp9 @ 000002327295ca00] --prefix=/mingw64 --target=x86_64-win64-gcc --enable-vp8 --enable-vp9 --enable-vp9-highbitdepth --enable-vp9-temporal-denoising --enable-runtime-cpu-detect --enable-postproc --enable-pic --enable-shared --enable-static --enable-experimental --disable-examples --disable-docs --disable-install-docs --disable-install-srcs --disable-unit-tests
[producer avformat-novalidate] D:/Shotcut/file/filename.mkv
checking VFR: pkt.duration 16
[filter swresample] 2(stereo) f32le 44100Hz -> 2(stereo) f32le 48000Hz
[swscaler @ 0000023272ea9040] Warning: data is not aligned! This can lead to a speed loss
[mp4 @ 000002326abee800] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.
[mp4 @ 000002326abee800] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.

I have seen this message before in some of my exports.

In those cases, something in my edit was forcing the hardware acceleration (GPU) to fail, forcing a fall-back to CPU rendering, which is slower.

(Or causing the Export to fail altogether.)

How does VP9 fit into this picture? Are your sources in VP9? Are you exporting in VP9 and we’re seeing two logs smashed together?

Providing a lot more information will get you the help you are seeking.
i3 what?? How fast is that i3 (model number)?
Source file specifications? (As shown in Shotcut’s property window)
Video Mode? (on the timeline, click on Output, then Properties)
Any filters used?
When exporting, are you just using default settings, or are you selecting a export preset?
Have you entered Advanced in export and changed settings? If so, what have you changed?

Also try disabling anti-virus, and any other programs before exporting. Windows10 enjoys to download it’s updates in the background without your knowledge, thus decreasing your performance.

When you are looking at any log in Shotcut, you have the ability to save that as a text (txt) file. Then you can just upload that whole text file in the forum’s reply window. This way you don’t have to copy/paste hundreds lines of text.

Just now I did a pair of Exports on a tiny test project, because I was curious about the reference to videolan dot org. It turns out that is the source of the libx264 CPU-based codec, thus confirming that something has caused

  • an attempt to use the GPU
  • GPU failure to initialize
  • CPU codec fallback

How does this effect Export time?
In my test case:

  • GPU (h264-nvenc) - 36 seconds ( 52 MB output file size)
  • CPU (libx264) - 111 seconds ( 30 MB output file size)

That is a more than 3x increase in time for the CPU Export.

Dude, what is VP9 here?? What do you mean two logs being smashed together?? Like I said, been using shotcut for years and never had such problems and the videos I’m trying to export are exactly the same ones I had exported so far. Ver. 0501 sucks, I guess. :(((

Thanks for your reply. I don’t have the foggiest idea what this videolan-org is all about. Never seen or visited this site before. Thought it was some sponsor site for this developer.

Now I’ve tried exporting several videos I had exported last week (which took less than an hour) the same way with this 0501 version and the export time is through the roof, too. 5 or 6 hours. Maybe it’s time for me to start learning to use a different video editor?? :(((
It seems you’re very knowledgeable in this kind of stuff. Any tips??

Well I went and read what has been updated with this version and they insist “time remap” (???) will boost exporting speed and I think this probably is the cause of all of this nonsensical exporting time. I bet they tweaked something with the exporting function and something went awry. They really need to publish a newer version asap. :(((((

5-6 hours…

Yes, that happened to me too, back in 21,03.21, when I just added one more filter to the edit, not knowing that the particular filter I added was a CPU hog.


Read more carefully.

As I said, my own curiosity about videolan is what led me to discover that you are attempting to use a GPU (which is probably what was giving you such short Export times), and the GPU on your computer did not initialized.
You were fortunate, at least you got a video; many times if the GPU does not initialize you get a black screen or an Export crash. In your case, Shotcut defaulted to CPU Export, which takes longer.

Have you tried this?

Another tip:
When you ask for help, and people here try to help, provide them with the information they need to help you.

Such as:

What filter did you add in the 0321 version?? Can you recall?? Still, that won’t help bc I’m using this program exactly the same way I’ve been using. Maybe I might as well google on what caused this gpu initialization fail. You have a good day!

Most likely, the “Use Hardware Encoder” checkbox was checked on previous exports, but isn’t now. Re-checking it would speed up the exports if that’s the case.

If hardware encoding fails initialization, there is no fail-over to libx264. There is just failure, usually a solid black screen in the exported video file. So the log is telling us that libx264 was specifically chosen as the export format, either on purpose, or because the hardware checkbox is no longer checked.

The log also says one of the sources is in VP9 format. This is what opening a VP9 source file does in the log:

[chain avformat-novalidate] /home/mint/Videos/vp9.webm
missing hwaccel parameters. skipping hardware initialization
[libvpx-vp9 @ 0x55efbc917740] v1.9.0
[libvpx-vp9 @ 0x55efbc917740] --prefix=/root/shotcut/Shotcut/Shotcut.app --enable-vp8 --enable-postproc --enable-multithread --disable-install-docs --disable-debug-libs --disable-examples --disable-unit-tests --extra-cflags=-std=c99 --enable-runtime-cpu-detect --enable-shared
[chain avformat-novalidate] /home/mint/Videos/vp9.webm

The missing hwaccel parameters line means there is no VP9 hardware decoding. It is not related to hardware accelerated export encoding at all.

As for CPU-hungry filters, the Reduce Noise filters are pretty slow if you used those.


This particular message is new and is related to hardware accelerated decoding. The engine now supports it but it is not used in Shotcut. It rarely makes sense outside of a simple media player unless you guarantee a full GPU processing pipeline, which is very difficult. See the FAQ for more info.

Thanks a lot for your smart input, Austin! I did what you told me to do - checked the Use Hardware Encoder tickbox. Still, it managed to quicken the exporting time only by about 1 hour…so now 6 or 7 hours to fully export a 30-min mp4 vid. :(((

Other features I can say is the codec it uses h264_qsv and hevc_qsv (currently it is on the former codec to encode) / rate control: quality-based VBF / quality: 55% (qscale=24) / GOP 300 frames / B frames 3 / codec threads 0

So I have it all reset and checked the hardware encoder option, and everything is the same as before. I pretty much bet this version does not work or is not compatible with my computer?? Or should I contact the manufacturer for any automatic sw upgrade?? :((

Anyway, thanks a lot for your help. I think you really do know what you’re doing here. :slightly_smiling_face: :+1:

I do believe there is something that is totally not working with the 0501 version! You guys really should do something about this, dude! Never had any critical problem with shotcut ever since I started using it for years now. Unable to upload any youtube video this week, or god forbid, this whole month, because of this terrible bug, man. This was unexpected and indeed frustrating. Ugh!!

Thank you for the enlightenment.
Always more to learn.

There is no problem here. You even wrote the previous version acts the same. No, it is just your weak i3 computer, or you doing something different here than previous uses.

they insist “time remap” (???) will boost exporting speed

We NEVER said that, and that is not what it will do. In fact, it can often make things slower.
You need to check your attitude before posting again, or I will silence you for a few day for trolling.

I’m on Linux and hardly ever use Windows these days, so I’m running an older stable version in my /opt folder alongside a recent release, just in case there are unforeseen issues such as yours. But you say you’ve never had any issues with other versions and its only vers.0501, so wouldn’t rolling back (reinstalling) to the March version you reference solve your problem? I don’t see what the big deal is, but I’m probaby missing something obvious.

EDIT: Yeah, I am. I see now included in a reply from @Shotcut that you have reverted to 0321, sorry about that. So if I understand correctly, you are saying version 0321 used to work prior to the upgrade, but doesn’t anymore? I mean, since you mentioned you’ve had very few problems up until now, I’m making that assumption.

One alternative is to choose a system restore point prior to the problematic version upgrade.

This is not needed since you can install any prior version to run without any problems with your computer. Your MLT project file may suffer unwanted results switching versions though. You can also run any portable version (zip file for Windows) without installing it.

If you do switch versions, always work with a copy of your original MLT file.

OK thanks, so a non-issue then.

This topic was automatically closed after 90 days. New replies are no longer allowed.