6 Channel audio issue dependent on framerate?!

Hi All,

I’ve got since a few months a problem with movies with Dolby Surround.

The source is a video file with H.264 codec and 50 fps. The audiolayer has got 6 channels with AC3 codec.

I’m exporting the file with the same audio and video codec, but a lower bitrate.
When I’m changing the framerate to less then 50 fps, I get only a stereo Audio. When I use the same settings but with the original framerate I get a right 6 channel audiolayer.

I’m using the Shotcut version 18.11.18 under Windows 10.
Older versions didn’t have this problem.

Has anyone an idea how i can fix this?
Thanks for any help!

I don’t have a 50fps file with Dolby Surround. I tried to recreate your problem with this file. It is 24fps.

Here are the steps I used:

  1. Choose Settings->Video Mode-> HD 1080p 30fps
    (choosing 30 so that the frame rate will be converted)
  2. Choose Settings->Audio Channels-> 6(5.1)
  3. Open the file linked above
  4. Open Export panel
  5. Select “H.264 Main Profile” preset
  6. Click “Advanced”
  7. On the Audio tab, choose Codec->ac3
  8. Click “Export File”
  9. Wait for export to finish
  10. Open the file and observe that the exported FPS is 30 and there are 6 audio channels

I can’t think of a reason that the framerate conversion would cause the audio to be downmixed. So I wonder if there is some other reason this is happening to you.

Can you provide step-by-step instructions to recreate the problem along with your source file?

If you change the frame rate or resolution in Export > Advanced, Shotcut uses a special “adapter mode” of export to render the project at project settings (“Video Mode” in Shotcut) and then adapt that output to the export settings. More than likely this adapter does not properly handle the audio channels setting. Basically, if you want 50 fps output, you should be composing in 50 fps to avoid this problem and possibly others. Meanwhile, we will accept this as a bug pending confirmation.

Thank you for the answers!

With your help I found a solution!

At first the step-by-step instruction to recreate the problem:

This is a example source file.

  1. Choose Settings ->Video Mode-> automatic
  2. Choose Settings -> Audio Channels -> 6 Channels
  3. Open the file linked above
  4. Open Export panel
  5. Select preset “default”
  6. Change framerate to “30” fps
  7. Change audio codec to “ac3”
  8. Click “Export File”
  9. get this

This file seems to have 6 audio channels, but if you control it with the audio level meter, you will recognize that only two channels are used.

The Solution:
I choose under settings -> Video Mode -> the settings i want as output

In my case:
“HD 720p 30fps”

Then I get 6 channels in my output file!

I tried to follow these instructions, but I am unable to recreate the failure. My output file has 6 active channels with the correct sound in each channel. I see from your output file that the output has 6 channels, but there is only sound in the first two. We will need someone else to see if they can also recreate the problem.

I reproduced it by changing Export > Advanced > Video > Resolution but not Frames/sec alone.

I fixed this bug for the next version 18.12 due later this month.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.