3D Text does not appear in exported video


#1

Hi, I’m fairly new to shotcut, so it might be something simple. The other posts I found on this topic did not seem to have answers, I’m hoping to get one here.

I’m in the final stages of my project and the Shotcut version of the video looks absolutely perfect. However, when I try to export it (regardless of file type, I’ve tried MPEG-4, the “Youtube” preset, the DNxHD preset now) the video is there and the audio is there, but the text that I added on does not appear at all.


#2


#3

I’m not a fan of 3D text but I tried an export and it worked fine. Try to upload the mlt file and a small clip to see if it works here.


#4

I agree, 3D extruded text is so 1990’s.

But make sure that your video mode setting match the video source BEFORE you import the video source.

It might be that the 3D text is being rendered outside the bounding area.


#5

Hey, thanks for your response, and I agree on the bubble text being very WordArt-esque circa 1996, but it draws attention and I’m a 90s baby so I have to represent! Can you please elaborate on how I should be preparing my video prior to importing? Because I don’t do anything before importing/editing and that could very well be my answer.


#6

Will certainly upload the clip when I get home. Thank you for your response.


#7

I recommended to set your video mode to match the video before you import the video. No changes to the video are necessary.
Go to Settings>Video mode.


#8

As soon as you add the 3D text filter to the source clip, just try to redrag it over the one on the timeline to replace it.