3D Text Crash (html)


#1

Hello everyone,
On another PC identical to mine on which I did not have any particular bug, as soon as I want to apply a 3D text (Html), the application stops responding and must be stopped by force. This is a systematic bug on this filter. Does somebody have an idea ?
I have a PC I7 Dell XPS 2710 all in one 27 inch 8GB ram 3.10 Ghz under Windows 10.
Thank you


#2

Confirmed with Shotcut version 18.11.18 (64-bit)
It just hangs, have to manually shut down Shotcut.
shotcut 3d crash log.txt (23.5 KB)
Windows crash log.txt - Shortcut.txt (2.8 KB)
Windows crash log2.txt - Shortcut.txt (1.6 KB)

Steps:

  • Open up one MP4
  • Drag to Timeline

Windows 10 Home 64-bit (1803)
i7-7700k, 32gb Ram

Before applying the filter:
Taskmgr_2018-12-03_14-46-32

After applying the filter: (Source not on the timeline)
Taskmgr_2018-12-03_14-47-10
After applying the filter: (Source on the timeline)
Taskmgr_2018-12-03_14-48-57


#3

Nothing changed in this area (3D Text filter, WebVfx, QtWebKit, Qt) for this version. 3D Text has always been flaky for some people. It is working for me on Windows 10 on my 2 machines. Did you verify it works in a previous version? Maybe it depends on your Display Method in Settings, but it works for me with either OpenGL or DirectX. In any case, this is not something I have been able to improve as bug gets deep somewhere in WebKit and OpenGL. So, at this point, either it works for you, or it doesn’t.
It would be a little interesting to hear if the Rutt-Etra-Izer works for you as it uses WebGL as well.


#4

The 3D text never worked well for me. Oddly enough with version 18.11.18 it’s working.

Made a test with some 3D text and the Rutt-Etra-Izeriter filter. It works, I can save it and open it. Tried to export to gif. Failed. Tried to export to mp4. Failed.

Both the gif and the mp4 were exported and play. Yet I have a failure log for both.

Attached all the files.

3D and Rutt.zip (487.1 KB)

Windows 10 Pro.


#5

I tried the filter many versions ago, didn’t care for it, but haven’t tried it again until now.
Just tried it with 18.07.02 and it works fine for me. Just the 18.11.18 will not work. Didn’t test other versions yet.


#6

Your mileage will vary. There are open bugs on github for a long while now:

Closing this for further discussion and people can track progress or submit fixes on those reports.


#7

Export works for me:

Your export job log shows a WebGL code dump, which I do not get:

THREE.WebGLShader: gl.getShaderInfoLog()
1: precision highp float;
2: precision highp int;
...

I did not intend for you to test the combination of 3D Text and Rutt-Etra-Izer, but that works for me too without gl.getShaderInfoLog(). Obviously YMMV, and believe it or not there are some difficult bugs I am not capable of solving, or at least I do not want to spend 6 months working on only a single bug. :wink:

Both the gif and the mp4 were exported and play. Yet I have a failure log for both.

This happens because there was a crash during cleanup at exit. This is a typical problem with complex software. More often than not, it goes unnoticed without some crash handler with a modal UI. In the case of Shotcut export job, it unfortunately results in a false negative.


#8