2h DVD with 4x VOBs import as less than 14min each

Hi, I have hit a snug. I converted a VHS and so the resulting dvd I ripped and cleaned up with DVD Shrink. I open the image and drop the VOB’s into shotcut (any version) and they read less than 14min each. I know the DVD is 2 hours so each section should be at least 30min.
When opening the vob’s in AVIDemux, it all opens fine and total time is correct.
Same when I convert with XmediaRecode, it’s all ok. I tried microsoft Movie Maker and same thing happened as in Shotcut.

With avidemux you can try to attach all VOB files and transcode a new video into another compatible container (in one file), without quality loss.
have you tried this?
I don’t have a VOB to test, so I can only make cheap hypotheses.

1 Like

I used avidemux and it worked very well. What I was curious about is why shotcut is not recognizing the vob and can it actually do that. Shotcut is a good app and I was hoping not to have a need to use any alternatives.

1 Like

Wild guess here… do the VOB files have any chapter markers in them?

Indeed they do. However the chapter is 5min in and the file shows up to 14min in. Still what you alluding to can still be the cause just not the first chapter marker. I will check that out.
If it is, it still would be better to use avidemux to fix it.

Would be so cool to borrow some code that makes avidemux so good at it and have it in shotcut.

We use the duration reported by FFmpeg. You can compare with the duration that ffprobe reports, preferably using the ffprobe that Shotcut provides. If you use Properties > menu > More Information… it runs Shotcut’s ffprobe with a detailed view showing the duration of each stream (track) and format (container).
You can override the detected duration in Properties while the clip is in the Source player.