21.03.21 installer failed

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
Not sure - it won’t open any more since it “died” while installing 21.03.21

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

Yes, tried it a few times - but had to abort.


Now SHOTCUT won’t open. I get this:


SOLVED - not sure why.

I tried “UNINSTALLING” (using Add/Remove programs)- but it said it couldn’t do it.

So - I renamed the Shotcut Folder under Windows Program Files to “X-Shotcut”.

Retried the installer - and it worked fine. As does SHOTCUT.

cheers, Alan

The installer and uninstall failed because files were locked by Windows because either Shotcut or its background exporter melt.exe were running whether visible or not. You can kill them with task manager or reboot to remedy that.


Thanks - as per my update, I’d got it working.

But yes, I think SHOTCUT might have been running. I had opened SHOTCUT, clicked on the “click here to install 21.03.21” - and it opened and I went from there.

I don’t recall if it closed SHOTCUT or not.