2 issues (possibly bugs?) I found whilst using the slideshow generator

@shotcut and @brian,
Hope you are well. I found a couple of issues (unexpected behaviours) whilst making a quick slideshow yesterday.

I made a video to explain what I found:

Issue 1 concerns the playlist (not the slideshow generator)
When no playlist items are selected, I tried to select them all via the hamburger menu.
“Select” is available, but all the submenus, including “select all” are greyed out. This is not what I was expecting. To select all items, I first have to select one of the items first, which seemed odd to me. I was expecting to be able to select “select all” without first having to select an item. Or is it me?

Issue 2: After creating a slideshow (works fine), I decided I didn’t want the first image, so I delete it (and the first transition).Then I selected “Ripple Track”, selected the entire slideshow clips and moved them along to the left…

… result - strange Size and Position keyframing. The image appears smaller in the top left and seems to move diagonally.

It also happens if I then delete the previous 2nd clip (which is now the first clip).
Are these bugs or am I missing something? Thank you.
PS version 23.12.15; video mode 1080p 30fps; images are all 1920 x 1080 PNGs.

Are you shure that all your images do have exactly 1920x1080 pixels?
Darktable as an example does not always scale the image to the exact pixel format.
Only images with the exact video output format and the disabled zoom feature do not create keyframes in the postion, scale and rotate filters of the slideshow!

Unable to duplicate issue #1.
Also attempted by using the same file name structure File Name (1).png with multiple files in series.

Shotcut 23.12.15, same video mode as yours.

Hi @alex007 - Yes, sure. In fact, all the images were on this occasion exported frames from Shotcut taken from a video.

Hi @Hudson555x , how strange. I’ll try it out with other images…

Now this is quite odd - I just opened shotcut and did this:
Open file …
Selected a random folder on my desktop containing images.
Selected a few images (they happened to be jpgs)
Return. Images added to playlist.
In hamburger menu - “select”
Result - “Select all” worked (NOT greyed out).

But then, tried the above steps several times more, and “select all” is greyed out again.
All further attempts have failed.
I tried closing/re-starting SC. Still greyed out.
I went back to the folder with images that worked. This time it didn’t work.
Quite odd??
I’m trying to think if there are any logical reasons why this is happening but can’t think of any right now. Will test some more…

I see in the Playlist code that it will only enable many playlist items when selection has changed. For many of these, that is valid because it depends on selection but not Select All and Remove All. I fixed this for the next version.

The reason for the slideshow image size problem is unrelated to Ripple. The problem occurs from deleting the transition and related to the simple keyframes whose begin and end extend into the transition. A workaround is to slightly trim the problem clip. That makes it adjust simple keyframes. It seems a similar adjustment is needed when deleting a transition.


Brilliant - thanks Dan. Once I knew it worked by first selecting a playlist item it was no big deal but I’m thinking of casual users who may be confused why “select all” was greyed out.

Ah, OK, that makes sense.

Thanks @shotcut. Could you just confirm what you mean by “turn off slightly trim the problem clip”? Did you leave out a word there? What do I turn off? Cheers.

That was a typo, remove “turn off”

1 Like

Thank you Dan, gotcha!