16:9 DVD export aspect ratio

What is your operating system?
Linux

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
22.09.01

Can you repeat the problem? If so, what are the steps?
Create a 16:9 aspect video, like in 1920x1080@25 fps. Choose export as DVD PAL. Set the resolution to 720x576 (this is the largest the standard permits) and set the aspect ratio to 16:9. Export. You get something tiny with black bars. Change the aspect ratio to 32:18 (or anything else actually canceling to 16:9) and export now. You get the desired 720x576 with correct aspect ratio.

Apparently 16:9 aspect ratio is hardcoded for producing nonsense, and fooling Shotcut by writing 16:9 not in shortest terms will sidestep that nonsense.

That is, to put it mildly, annoying.

Sorry, but I’ve spent lots of hours on this and the video mode is the video mode of the source. The widescreen export options also don’t work and result in black bars and much lower resolution than the standard demands.

The output of ffprobe on the vobs should be something like

Stream #0:1[0x1e0]: Video: mpeg2video (Main), yuv420p(tv, bt709, progressive), 720x576 [SAR 64:45 DAR 16:9], 25 fps, 25 tbr, 90k tbn

That gives the best possible resolution for 16:9 videos and there is no area wasted on black bars. Pretty much the best you can do when producing a DVD. Shotcut’s normal export options don’t create that kind of content.

Are you telling me that it is supposed to be a feature that exporting in 16:9 delivers different results (and much inferior) from 32:18 aspect ratio?

You are correct that is should work and is a bug. Something like 1024x576 16:9 is fine but not this. However, you can change the video mode quickly and temporarily if nothing is spatially positioned. It does not matter the resolution of the source. (Actually changing the resolution at export makes any source not matching Video Mode worse by resampling twice.) If you do have some things spatially positioned, as a workaround, you can export a high quality intermediate file and then transcode that.