XDG_RUNTIME_DIR points to non-existing path

hello,

This is a low priority. I recently installed shotcut on Ubuntu 16.04. AFAICT, video import, editing and export works without any problems, unlike a similar error message.

When I run shotcut -v from the command line I get:

shotcut -v
QStandardPaths: XDG_RUNTIME_DIR points to non-existing path '/run/user/1000/snap.shotcut', please create it with 0700 permissions.
Shotcut 19.09.14

My desktop environment is gnome, I installed shotcut via AppImage.

I am not sure if I should create the folder, or ignore the message at this point.

I see this when I run a snap, and it is not causing a problem for me. You said you are using AppImage, but this message is clearly coming from snap given the path in the message. I do not see this when running the AppImage. I did a little research, and it is not clear to me if something should be done. It can be used to provide a temporary directory, but Qt QStandardPaths still finds a temporary at /tmp on my system.

1 Like