Windows: Shotcut isn't listed in right-click Open with menu

Windows 10 64 bit, when I right-click on a media file I don’t get Shotcut as an option. Even though I’ve made Shotcut the default program before. Instead Windows offers me absurd options like Notepad or programs which I’ve never used once.
This forces me to go down to “Choose another app”.

Windows 10 64-bit, works for me.
I rarely use this function in Windows, and I don’t recall ever setting Shotcut for any file type.
explorer_2020-05-07_03-31-34 explorer_2020-05-07_03-32-26
explorer_2020-05-07_03-29-35 explorer_2020-05-07_03-30-28

Following along though to see what your issue is and how you solve it.

Interesting that Shotcut is listed for you also as shotcut.exe.

I’ve even manually made Shotcut the default application for mp4 file extension. Still, it doesn’t appear in the right-click “Open with” menu.
Not a biggie, but I’d like to understand it.

This topic was automatically closed after 90 days. New replies are no longer allowed.