White Preview Window

Okay so first the preview window was black, but my timeline was still there. I’ve read on the forum to make sure I had no filters, I did not. Then I tried changing the display mode, which ended up in me receiving the OpenGL 2.0 or higher error. I’m not sure what happened, but eventually I was able to open shotcut again. Now my preview window is white. This is addressed in FAQ. But I’m not able to follow the instructions clearly. I’ve right clicked on properties, where/what is the “video tab” to make sure it is enabled? I also explored settings to make sure GPU processing is disabled and could not find that either. Then I did try changing display mode to DirectX, which I already tried before and that did not work.

I have a Windows Surface Pro 4. It may not be able to handle this program and maybe that is why I’m encompassing this snowball of events, which sucks cause I was really enjoying the program at first. (yes it did work the first couple times and I was able to edit my video quite a bit and then I opened shotcut again and all this started happening.) Any help/guidance is appreciated.

Windows 10 Pro
Processor: Intel® Core™ m3-6Y30 CPU@0.90GHz 1.51 GHz
Installed RAM 4.00GB
System type 64-bit os, x64-based processor
Graphics Driver: Intel® HD Grpahics 515

Memorial Day 2020.mlt (567 Bytes)

I too have a Surface Pro 4 with 4GB of memory (admittedly with an Intel Core i5-6300U CPU @ 2.40GHz. It runs small Shotcut projects reasonably well.

I just fed it an empty project such as yours and up came the “preview screen” (Source Viewer) in white. I opened a video file and it was OK, and at this point the timeline appears and the parts of the source viewer not obscured by the video are black. My display is set to DirectX (ANGLE) and it works fine.

So what you are describing is not a problem.

… you’re saying that it’s not problem for you? Could it not be because you have a better GPU?
I’m just trying to figure out why my project is now “empty” and as I said, there were a couple events leading up this that I’m having a hard time figuring out. Like why was it black first and now white? I currently have mine set to DirectX and it’s still white. I am able to pull up my raw unedited footage (mp4) in shotcut and I could start from scratch. But I’d like to know why this problem occurred, if it’s preventable, and if it’s at all possible to get my project back…
Nice to know you have no issues with it and your surface though.

Sorry, it wasn’t clear from your description that you had been editing a project and now that project is empty. I thought you were just querying why you have a white screen when you start a project, also since the title just said “White Preview Sctreen” .

The MLT file you uploaded is empty, so you are not going to be able to continue working on your project from that. If you made a backup at any time you could continue your editing from that. It is always a good idea to backup your project (indeed all your files) on a nightly basis. If you don’t have a backup there is a small possibility that the project may be saved in the “autosave directory/folder”, it is unlikely though, but have a look in the menu item:

Settings -> App Data Directory ->Show->Autosave

Other than that I don’t see any option other than starting again from scratch.

Thanks for getting back to me. Not to be snarky, but I state in my second paragraph that I was already editing the video. It had been autosaving just fine for me the first couple times I exited out of shotcut and opened it back up. I’m really trying to get to the root of the problem, or at least know how to fix it, in case it happens again. I’d hat to start a new project and have the same thing happen. I may just turn to new software…

Hi Kaylee, following up from Twitter, yeah this project is indeed empty. I have not explanation for how Shotcut could have removed everything in your project. Maybe while you were struggling with something you did a Save As and overwrote your existing project with nothing. As like most powerful tools it can be easy to hurt yourself. There is no way to get your project back unless you have an older copy of the file somewhere else on the hard drive or a backup. If you do not have a backup, maybe now is a good time to consider it.

That’s OK, I realise how frustrating it must be for you to work on a project for some time only to have it vanish.

I wouldn’t give up on Shotcut though. I have rarely had any problems with the software and nothing as major as what has happened to you. For free open source software it really is in my opinion the best video editor out there. It has a lot of features that you normally would only find in expensive editors, Dan, Brian and others work really hard to improve it month on month and the community here on the forum are always willing to try and help anyone who is having problems.

When I finish a Shotcut editing session I always save a sequenced backup of my MLT file and I usually keep three of them. I come from a computing background where in the old days disk crashes were quite commonplace and if you didn’t keep a backup you could lose a lot of work.

Talking of backups, I do a backup of all my files to a 2-terabyte USB3 disk every night. I use a free backup solution called SyncBackFree. I set a profile to look through my Documents, Video, Photo and a couple other folders and it copies any that have changed or have been added since the last run to the disk. It also protects against “ransomware” and accidental deletes. It takes just a few minutes (sometimes just seconds) to run each night (once the very first backup has been run) and gives me peace of mind. I cannot emphasise strongly enough the need for backing up your data. SyncBackFree (https://www.2brightsparks.com/download-syncbackfree.html) only runs on Wiindows, there are other solutions for Apple systems (e.g. Time Machine) and Linux (e.g. Time Vault).

EDIT: For Linux: Time Vault hasn’t been maintained for some time, you might want to look at Restic or Borg instead.


I understand that, but I was never saving anything. I was only using the autosave feature. It all started when my preview window turned black, I could tell it wasn’t empty because my work in my timeline was still there. I have a feeling my project became empty as I was following forum advice and trying to fix that issue…

Thank you Elusien! I will try SyncBackFree. I will give shotcut another go. I was just concerned because this happened like the first day I was using it after editing for a few hours. But I really appreciate you getting back to me!

If ever you have a problem before you start trying various things to fix it make a copy of the MLT file before you do anothing out of the ordinary. At least then you have a fallback. Good luck and if you have any further queries don’t hesitate to post them on the forum.

1 Like

@Kaylee_Salter - Good luck from me too! :laughing: Yes, don’t give up with Shotcut yet - what happened to you has never happened to me in years of using it, so it’s an unusual thing. I agree with @elusien - there are a friendly bunch of folk on here willing to give advice/help if you need it.

@elusien, thanks too for the SyncBackFree link. Just downloaded it and it looks like it could be a must-have.


Will do!! Thanks!

Haha I appreciate the energy. Thank you!

This topic was automatically closed after 90 days. New replies are no longer allowed.