When importing a clip, Shotcut adds two black columns

Is this a problem with the resolution?

When your source resolution/aspect ratio doesn’t match your video mode, yes.
Settings - Video Mode.