When I open a project, Shotcut starts using 100% HDD read bandwidth and doesn't stop

What is your operating system?
Windows 10 64-bit
24 GB RAM
4-core i5-6600k 4.5 GHz

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
20.10.31 64-bit

Can you repeat the problem? If so, what are the steps?
I open up my project and Shotcut immediately starts reading my HDD, not allowing me to add more files (it’s using 100% storage bandwidth.)

When I choose “New Project” it still doesn’t stop reading my HDD, even though the previous project should have closed.

P.S. This is like the 5th bug I found in the first hour of using Shotcut. I’m slowly giving up. (Others included crashing when importing many large files, freezing when adding many large files to the timeline and playback crackling - OpenShot doesn’t have problem with anything like that but has less features.)

Shotcut must validate that all of the video files exist upon opening the project. Then if thumbnails or waveforms are not cached those are regenerated in the background. That is probably what you are experiencing. When you choose Close, it does not stop the background tasks to generate waveforms because that work is only cached when it is complete, and it does not want to discard the progress it has made. If you want it to stop, you can quit Shotcut. I have no plans to change any of that because I like those behaviors.

So it is because of the waveforms. Thank you for clarification. I just wish Shotcut didn’t have to do that each time I started the project.

I concluded that waveforms weren’t even useful in synchronizing picture-in-picture because of how imprecise they look, so I’ll just disable them.

Zoom in on the timeline and the waveforms are plenty accurate for sync. People here do it all the time.