Video only exports without text filters

I was delighted to find that the newest version of Shotcut includes rich text, as I am using it to prepare clips to make into gifs and wanted to add lyrics to a video. I downloaded the most recent version yesterday, 09/20/20.
I am trying to export a video that consists of a few very short sequences (the whole thing is thirty seconds in total) that all have different text on them. I have used the filter Text: Rich to add text, it all looks fantastic in the programme. The fonts I used were YU Gothic UI Light and Vladimir Script, though I doubt it’s down to the font.
But when I export the video (into mp4, export from timeline, no audio), I get the video, but none of the text. The other filters I added (saturation, brightness) are there, the video quality is exactly as expected, it’s just the text filter that is missing. Does anyone know what I might be doing wrong, or is this a bug?

It sounds like you are experiencing the same bug that was reported on in this thread:

I actually tried what was suggested in that one, but it didn’t help - but I’m also pretty sure it’s not quite the same issue. I think what I am experiencing is not a bug but rather a mistake in handling the programme, because the user who reported the problem you mentioned said the text she tried to add was cut off, whereas mine is just completely missing… it’s almost as if I had to somehow stamp the text on and didn’t do that, if that makes sense.

In the thread, I mentioned I came across an issue too which was not the same as hers but mine had to do with Parallel Processing being on and not having the text show up and/or flickering. Did you test exporting with Parallel Processing on and off to see if it made a difference?

1 Like

thank you for the tip, but I’ve tried it both on and off (it was off by default), and the result was the exact same. Also tried saving the timeline as source and exporting that instead, but no joy there, either.

Alright, while it doesn’t solve the problem, I think I can prove it’s a bug with the rich text filter. I tried doing the whole thing over with the simple text filter and turns out it works just fine with that one!

There is a known bug if the background height is smaller than the text size it will not show when exported.



This topic was automatically closed after 90 days. New replies are no longer allowed.