Video Fade Filters problem

Hello,
I am trying to add ‘Fade-in’ and ‘Fade-out’ filters, using the ‘Adjust Opacity…’ but somehow it does not work, or I do not know how to use it. (or some bug ??)
Here are 3 short samples to demonstrate, in a zip file.
.
Sample-1-B : Fade-in and Fade-out applied , works OK.
Sample-2-B :In Fade-out filter added Adjust Opacity…, Fade-in works, Fade-out - like no filter.
Sample-3-B: In Fade-in filter added Adjust Opacity…- like no filter.
Samples.zip (4.1 MB)

Shotcut version 23.07.29
Window 10 pro, Winver 19045.3324, 22H2 X64.
Answers will be appreciated.
Thanks
Motim

I have not looked at your zip files because fade in and out works perfectly fine. You simply need to remember that Shotcut does not automatically blend with the hidden black background, and opacity needs to be blended with something in order to be visible without the special magic viewer called the Alpha Channel: View video filter. This means using the opacity checkbox on a video track with nothing underneath it is usually useless - unless you intentionally want that because you are knowingly exporting the alpha channel. If you do not understand what it means to intentionally export an alpha channel, then you are doing it wrong by using fade opacity (or keyframe the Opacity filter) with nothing underneath of it. This information has been repeated here numerous times.

This topic was automatically closed after 90 days. New replies are no longer allowed.