Video exports as 42Mbps, when it's programmed as 35Mbps


#1

This weekend I was editing together a video and I noticed that upon exporting the video that the file has the bitrate higher than what I set the average bitrate to. I set it to be 35Mbps and it comes out with 42Mbps. I tried setting the bitrate to 27Mbps and that got me the 35Mbps I was looking for, but the file was around the same size as before.

I’m using the Youtube stock preset, but I set the codec section so that it’s an average Bitrate of 35Mb/s, and also set the GOP to 30 frames (since I’m exporting a 60 FPS video and Youtube requires the GOP to be set to half the framerate).

This only started happening when I tried exporting the same video on the newest version, and the video eventually would get an export time of around 1.5 hours. So I downgraded to version 18.12, and the issue mentioned above started happening. I’ve tried fully uninstalling the program, and also deleted all the presets from appdata. I’ve tried older versions, with the same result. So I don’t know where to go from here…

Last month this was working perfectly fine, so I have no idea what caused this to start exporting the video like this.


#2

Are you using hardware encoder?


#3

I do not have the “Use hardware encoder” setting checked. This only appears to be happening if I have image files before a video file. I have tried converting the image files to a video file, but the same thing happens as before.


#4

If you want reliable average bitrate you should use dual pass.