Video choppy when i add filters?

When I add filters, the video becomes more laggy as I add more, anyway to stop that?
I have the most recent Shotcut and I have 16G of ram
Is there a way I can allocate more ram to shotcut?
Thank you

Buy a very expensive super powerful PC :slight_smile:

Don’t worry, this normal behaviour. Your ram is good but powerful processors and powerful graphic cards with more o/b ram are what helps here :wink: You have to understand that your video file is ‘uncompressed’ while open in an editor which you are then asking to ‘process’ frame-by-frame (which is a lot per second) with the filters and edits you have applied. Only when you encode and export will it be re compressed and smoothly playable.
Note that the same thing happens in other video editors once you start adding effects and other edits, some even worse!

oh thank you so much

so if i watch an .mp4 in another player, (such as msplayer or VLC or the like), it will present a little smoother?

When you are using ShotCut as an editor with splits, transitions, mixed tracks multiple source files and added filters (etc) it no longer performs as a ‘player’.
Once you have encoded your file and exported to (say) *.mp4 - then it will playback as smoothly as your particular computer hardware plays any video file.

actually, when i played back my first attempt at a closing credits reel, it displayed exactly the same way in windows media player, and vlc as it had in shotcut…basically pausing for a couple of seconds each frame…i have an idea for a different technique…if you have another idea that involves properly adjusting shotcuts settings and proceeding that way i’ll happily check that out…either way i’ll let you know how it pans out…

Wrong thread?

might be…i’m referring to two different threads… and responding to you at the same time…chances are this may just be the wrong thread, although the topic is kinda the same, you gotta admit.