Video and audio not in sync


#1

I tried shotcut maybe a few months ago and gave up since the audio was not in sync. Now I’m trying again and searched the issue because it’s still not in sync. I’m on a new laptop with windows 10. One suggestion was to go to properties, hamburger, convert to edit friendly and I did that but still not in sync. I come from movie maker and this is all so very different for me.


#2

What source file are you working with?
Can you supply an example?
Does your new laptop meet the minimum specs for the file you are trying to edit?


#3

@Darlene_Michaud, while I may not solve your issue, I’ve had a lot of audio sync issues as well. Mine was solved by downloading Realtek audio drivers for my computer after NVIDIA had one of their updates.

But here are a few things to check for. Use VLC media player to see if the original recording is out of sync first. For me it was. Other software may interfere with the operation of recording video. There has been a lot of major updates from Windows and NVIDIA in the past few months and do your best to make sure you have the latest updates, and if you are using Realtek drivers for sound/microphone it might help to just download the drivers from Realtek and install them as I’ve discovered a few. Going through the device manager and having windows check for the latest updates does no good as I actually had to uninstall the realtek drivers and reinstall them.

If you have the time, there are ways to fix the audio lag with Shotcut (if the raw recording is actually out of sync). If you have a mechanical (not an SSD) hard drive it make take up to 10 seconds for it to spin up from “sleep mode” if you’re not writing/reading from it.


#4

My original audio was not out of sync with anything else that I tried. Only on shot cut. I will just skip trying to use it. And I don’t even like the looks of it. I’m so used to movie maker and it’s bright, clean look. Everything else is alien to me. I’ll have to learn something new at some point, but not yet. Thank you for your help.


#5

Just now seeing this reply. Not even sure what a source file is. Just know I’ve never had any issues with this in movie maker so I’m still using that. I also tried a few other things and the sync was fine. No biggie. I’ll just give up on shotcut.


#6

No, don’t give up. It’s just learning how to use an NLE.

Movie Maker has coloured your experience & perhaps led you to expect all video editors should act the same. This is not true.
The difference with Movie Maker is that it automatically produces a cached/proxy file. Shotcut does not.

It is actually import what your source file is. Can you tell use if it’s a screen capture, camera video or smartphone video?

You can get more details if you use MediaInfo (google it, it’s a free app for all platforms)


#7

I’m desperate to learn something new. But I LOVE, LOVE, LOVE the huge waveforms I get with movie maker. I can know at a glance where I need to cut. Just so quick and easy. Yet with no support for it, one day it will be useless.

I record with my camcorder. And yes, I import it when in movie maker. I don’t recall doing an actual import with shotcut. Don’t recall that option.


#8

There are waveforms in Shotcut, certainly as useful as WMM. What format are your camcoder files?


#9

There is no Import in WMM, only ‘Add Videos’ - with Shotcut it’s ‘Open File’ - same function, different name.


#10

Not sure what you mean when you say format. MP4, is that what you mean? And how on earth do I get those waveforms on shotcut?


#11

MP4 is close enough :slight_smile:

Open your file, or drag it into Shotcut, then drag it from the preview window to the timeline.
Shotcut automatically creates the wave form.
It might take a while depending on how large the file is and your PC hardware.


#12

But will it look like it does in movie maker? That’s the part I don’t know how to do. I like the waveforms to be super big. I have it so you can practically see each word. I can even read some of the waveforms like reading music. I can tell at a glance when I said “and um” and can cut those right out.


#13

I like my waveforms to look like this. Big and separated.

waveforms


#14

No, it will look like it does in Shotcut.

Of course this is audio stream dependent, but your wave forms above will peak in a similar way in Shotcut.

Here’s an example where I’m speaking in this file with the same word shown in wave form peaks.

I recommend spending a liitle more time familiarizing yourself with the application rather than expecting it to be just like Movie Maker.


#15

You can increase the size of Shotcut’s waveforms by right-clicking on the timeline and selecting “Make Tracks Taller.” You can do this several times. And you can “zoom in” using the magnifying glass slider above the timeline.

bigger_waveforms


#16

Source file, that’s the file that came out of your camcorder. I hear that a lot of consumer cameras, output in variable frame rate, Thats why they want you to install MediaInfo and open that first file with it. then copy and past the text to here so everyone can know what you are dealing with If it turns out that it is a variable frame rate file, that would cause the audio and video to get out of sync. It is my understanding that Shotcut and most other video editors don’t like variable frame rate, that means you need to change it to a constant frame rate file, there are programs that can do that for you. Then you use the new constant frame rate file in Shotcut, or some other video editor.
This is a mp4 I took with my phone, this is the detail that mediaInfo can give you.
General
Complete name : C:\Users\lost_\Desktop\Joy.mp4
Format : MPEG-4
Format profile : Base Media / Version 2
Codec ID : mp42 (isom/mp42)
File size : 50.6 MiB
Duration : 41 s 610 ms
Overall bit rate mode : Variable
Overall bit rate : 10.2 Mb/s
Encoded date : UTC 2017-10-30 07:40:34
Tagged date : UTC 2017-10-30 07:40:34
com.android.version : 7.1.1

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : Baseline@L3.1
Format settings : 1 Ref Frames
Format settings, CABAC : No
Format settings, RefFrames : 1 frame
Format settings, GOP : M=1, N=29
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 41 s 602 ms
Bit rate : 10.0 Mb/s
Width : 720 pixels
Height : 1 280 pixels
Display aspect ratio : 0.563
Rotation : 90°
Frame rate mode : Variable
Frame rate : 29.422 FPS
Minimum frame rate : 29.335 FPS
Maximum frame rate : 29.508 FPS
Standard : NTSC
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.369
Stream size : 49.6 MiB (98%)
Title : VideoHandle
Language : English
Encoded date : UTC 2017-10-30 07:40:34
Tagged date : UTC 2017-10-30 07:40:34
Color range : Limited
Color primaries : BT.601 PAL
Transfer characteristics : BT.601
Matrix coefficients : BT.601

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC

If I were to open this in Shotcut, do some editing and then export it, the video and sound would likely be out of sync, As this video is only 41 seconds long it may not be noticeable, but it would be there.


#17

At the top menu, Go to Settings > Theme > select Systems theme or Fusion light

to change it to the bright and light theme


#18

Darlene, I am unsure if it will work, but you could try to copy your clips on the timeline to an empty videotrack (rightclick and copy the first clip, then highligt the empty videotrack and click the + icon and repeat until you have two similar copies above each other).Then lock the two videotracks with the locker and disable video in one track with the eye icon and audio in the other track with the loudspeaker icon and export.