Using "grab circle" changes preview window


#1

Shotcut 18.11.18 Windows 10

When I use a grab circle to add a video fade to a clip (either by double clicking or dragging the circle) the image in the preview window zooms in and shifts to the right and down. And not just on that clip, but on ALL clips in the project.

If I manually select Filters/Video Fade there is no problem.

If I exit Shotcut and restart it all is well.

Update: It now appears MANY things cause the preview window to go wacko. I bring up my project, delete an audio clip and BAM, the preview window does the shift/zoom thing for all video clips.


#2

I do not reproduce this. Are you certain you are using the circle fade control on a Timeline clip and not Keyframes?
Please provide a screenshot. This looks like a bug with the OpenGL code and your driver/GPU. Please specify your GPU/video adapter. Also, you can try changing Settings > Display Method to see if that helps.


#3

I’ve just been using the fades most of the day with 18.11.18.
I tried to break it by double clicking, although I’ve never double clicked where the handles are at for zoom on the timeline.
Windows 10.


#4

It turns out to be a much bigger problem than originally suspected. I can load up the MLT file that I have spent weeks working on and as soon as I do ANYTHING the preview display goes bonkers, always in the same way. It’s almost like a Size and Position filter I have made somewhere in the past suddenly rises from the dead and attacks. I need to do more testing to see if I can isolate particulars. BTW, with the exception of adding an additional 4gb ram I’m using a stock Dell Inspiron 3558, so I’m on the bare minimum.


#5

If you are currently on DirectX try with OpenGL and vice-versa. You can skip testing Automatic as that just tries to choose one of those two.