Unable to restore project after crash while proxies were on

What is your operating system?
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.10
Release: 20.10
Codename: groovy

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)
This time, I had a 4.4-GB MKV-file and an 1.6-GB MP4-file to play with. Once Shotcut finished the proxy for the former one, the whole computer froze for like five minutes following by a crash of Shotcut. I tried to restore the project but it kept loading it and same things happened: the whole computer froze for a while followed by a crash of Shotcut. This also happened as I retried to restore the project. An hour editing just went to the black hole unless you have an idea how to restore it without a crash.

Here is the application log:log.txt (30.6 KB)

I’ve also made a video on this topic.

The same happened tonight with no preliminy archras. While editing, Shotcut told that too much memory was in use and offered three options. One of them was Save. So I clicked Save which resulted with Shotcut restarting. After that, I couldn’t open the project anymore. Shotcut stayed hanging for a couple of minutes and crashed after that.

I also tried to attach the application log however this site here doesn’t accept a file if it has no extension. And Shotcut didn’t create an extensionapplication-log.txt|attachment (30.5 KB)

I also upload MLT-file: matemaatika-patrikuga-20210801-ristküliku-kolmnurga-trapetsi-lahendamine.mlt (788.4 KB)

The project file you shared is valid XML and loads for me without replacing any missing files. After substituting my own media and letting Shotcut finish generating thumbnails and audio levels it is using a lot of memory - around 5 GB - and eventually crashes. The debugger says it crashes somewhere in a library we use but related to audio waveforms. I turned off audio waveforms in the timeline menu, and now it loads. Your project is long with very many clips, and you may be pushing Shotcut beyond its capabilities on your machine. The issue I experienced needs further investigation, but I am not sure I can solve it or that it was the same problem you experience.

1 Like

These audio waveforms go incorrect anyway if using proxies. Yesterday, on another project, I experienced a delay even using originals: I heard the sound before the cursor reached the correct point on the waveform. By the way, Audacity also has a clitch regarding to the waveform. There, the cursor is in the right place but once I export as FLAC, it add some time after the segment ends. Maybe, it’s related.

Can the memory problem be solved using divide & conquer? Why does it need to keep so many things at the same time in RAM?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.