Unable to change speed


#21

It worked when I saved the mlt file to the network drive while bringing up the video file from dropbox. I also tried saving the previously dropbox-saved mlt file to the network drive and pulled it up again. I was unable to edit the speeds. So those speeds are fixed in somehow. I would like to still find a solution so that I can edit that video.


#22

You can try some simple workaround. You can open the original clip in the Source player, set the speed as desired in Properties, position the playhead in the Timeline (double-click a clip in the timeline to select it and move the playhead to its start). Then, use overwrite button on the Timeline toolbar.


#23

Hey, I just ran into this bug myself and fixed it! The problem occurs when the project and media file of the clip being change are in the same folder (or media in sub-folder of the project file’s folder). This situation causes the XML to store the file names with relative or no path. Then, many things in the Properties panel start breaking without a full path including Speed, Reverse, Convert, and so on.

A workaround is to move or copy the project file out of the folder. Open it from the new location and resolve the missing files (tedious, I know). Now, you can work on the “- Repaired” version of the file and copy it back to Dropbox occasionally for your backup/sync.

This has been fixed for v18.09 due in about a week.


#24

hi,

i followed those steps, but it didn’t fix it. yesterday i created a project with quite some clips, different speeds, lots of filters, etc., everything worked. today i opened the mlt file and the clip speed is “fixed”. pressing enter makes the value jumping back to it’s previously set value. moving the mlt to another location and resolve the media files was easy, but didn’t change that. i restarted shotcut several times.

version shotcut-win64-180814, on Win 10 x64, v. 1803, build 17134.228


#25

Next finding:

The clips with speed 1.0 are ok to change, but changes made on the ones with different speed result, everytime Shotcut is opened, in different behaviors.

After attempting to change the speed of a clip from ≠ 1 to another value i find different behaviors:

  1. The timeline bugs and selecting the clip isn’t possible anymore
  2. The timeline bugs and selecting the clip is possible,but moving it makes other clips moving uncontrolled to further or earlier positions on the track
  3. Nothing happens (speed change is discarded automatically)
  4. The speed changes, but the clip name changes as well and includes the newly entered desired speed and the full path to the media file ( ex.: from “0305.MTS” to “3:D:\XY/305.MTS”, slash and backslash).
    According to the properties, the actual path stays correct, but the little preview icon in the clip either disappears or shows unrecognizable pixel salade. After re-opening Shotcut it asked to located the file and after having this done the preview windows showed “Invalid” instead of the content of the clip.

4a) Result after copying the whole project folder to a place with shorter location name and without é in a folders name (from D:\XX\YY\ZZ\Sub1\Sub2… to C:\Temp\Project):
Changing the clip speed still kills the clip icon and name, but then saving and re-opening the mlt results in accepting the new speed and at least the clip name is restored to [relative path][/][media file name][speed]


#26

without reading every reply, i found this ofen myself. i think entering your new value and pressing ENTER is required, i’ve tabbed out and it does not apply often.

Sometimes, if i change it, say to 1.25 speed, i cannot change it again until restart shotcut.

Linux/XFCE, multiple versions of shotcut