Ubuntu 18.04 LTS + GTX1660 no GPU usage


I try to edit some 4K Footage with an Ryzen 2700 and GTX1660. When I play the unedited footage it works almost OK but after adding some Effects I im dropping a ton of frames.

Then i fire up nvidia-setting and see the GPU-Usage is on ca. 2-9% and the CPU-usage is on 8-16% but I have a unuseable slideshow. It does not matter if I use OpenGL or Mesa - just with Mesa I have a bit higher GPU-usage till 17 or 18% bus still a slideshow with 3-4 fps.

What can I do?

PS.: While exporting the GPU Video-Engine also get just used for 3-8% and the GPU run on 18-21%.

Looks like something hold the programm back and don’t use all possible power of the system…

You are assuming the video processing uses the GPU, but normally it does not and uses the CPU. There is a hidden feature to use the GPU through OpenGL, but it remains hidden because it is still unstable. You can enable it by manually editing the configuration file.

OK thanks for that. But what does then mean Settings -> Display Method -> OpenGL / Software (Mesa)?

And why I have a very poor CPU utilization as well - I guess a Ryzen 2700 should be able to play 4K MP4-Footage in Realtime even after tuning WB and contrast. So if it’s not the GPU-Rendering as I was thinking some other issue have to make the programm perform so poorly.

What could that be?

I have a R5 1600 and a GTX 1060 6GB and I have the same behaviours but I think its just because shotcut is limiting how much power can be used. Someone correct me if I’m wrong.

I have a R5 1600 and a GTX 1060 6GB and I have the same behaviours but I think its just because shotcut is limiting how much power can be used

OK in case that would be correct - is there a way to increase the limit? I really think Shotcut is an nice NLE but without realtime-preview of footage it’s hard to work with.

If the playback is so slow that I can’t even understand what people are saying or if the momement of talents are jumpy and not fluently - how should I find the right cuting-point…

So I guess there must be a way arround that or some setting to increase the performance.

Shit code. Send us your patches.
If you turn off Settings > Realtime, it will use more CPU, but not always because some things can not run concurrently. Also, it disables the video frame-dropping, and if rendering falls below realtime, then audio becomes choppy. This is the current situation. I cannot magically make it all perfect and fast. You can take it or leave it.

OK i found another workaround - I cut first and do the colorgrading later. Without effects the Realtime-Playback work fine.

One more thing would be great to have - the waveform in this way: https://www.cinema5d.com/wp-content/uploads/2015/06/Resolve_Scopes_Feature1-640x360.jpg

If you found time to do this it would be very nice…

This topic was automatically closed after 90 days. New replies are no longer allowed.