Timelapse, Keyframes and the Rotate & Scale Filter

Hi, I don’t know if this might be a bug or just me being stupid, so I figured I’d ask for help first.

I’ve loaded a sequence of pictures for a timelapse, which works pretty well. The images get exported to my chosen setting of 1080p with 24fps, just as I would on command line using the ffmpeg image2 format.

I then applied two Rotate and Scale Filters on the resulting clip, which works great for the preview.

However, when I export the video it’s just like there are no Filters applied at all. I just get the same video as with plain ffmpeg. Am I doing anything wrong here?

[Edit: Shotcut version 19.09.14. Input files are high quality PNGs generated with darktable]

2019-09-17, Timelapse Ali-Lanti-Biwak Sunrise.mlt (3.3 KB)

Screenshot%20from%202019-10-05%2012-40-25

Since I can only put one image per post…

Since I can only put one image per post…

Screenshot%20from%202019-10-05%2012-41-01

Since I can only put one image per post…

Looked at the project file you posted. There are no filters in the project file.

My guess is that you put the clip on the timeline, then applied the RS filter to the clip in the source viewer.. Then looking at your screenshot, you exported from timeline.

The clip on the timeline has no filters applied to it.

1 Like

Apparently I posted the wrong MLT. I tried again, this time from scratch, and it worked!

I guess I can attribute this one to user error.

Here’s a project file that’s working:

2019-09-17, Timelapse Ali-Lanti-Biwak Sunrise.mlt (4.4 KB)

Thank you very much! :blush:

Made a few of those myself.:grimacing:

1 Like