The 21.01.29 Timeline sliders are a disaster

What is your operating system?
Ubuntu Linux 18.04 (Kubuntu flavor) AMD64

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
21.01.29 64-bit
also
Shotcut-181118.glibc2.14-x86_64.AppImage
and
Shotcut 201128 linux-x86_64.AppImage

Can you repeat the problem? If so, what are the steps?
The new look and feel of the Timeline is an ergonomic disaster for me.

Is there any way that Shotcut, as an implementer of QT, can specify or modify the placement of the sliders?

Can you find the time slider in this screenshot? With my eyes, it tool a lot of searching.

I know it is a forced (by QT) change, but the loss of functionality for me is almost a show-stopper.

In my work, having the time markers always in view is absolutely essential.
Unless things are changed in QT or Shotcut, that means always using F11 fullscreen (not a big problem) and going to a 4K monitor to get all my tracks AND the timescale. (BIG problem on my budget)

In addition, it is never clear now what a click will do. Depending on scrolling, it might select a track, it might set the playhead to that time, and it might send the time focus flying to the middle or the end of the timeline.
If clicking the lower-right corner, all bets are off. Maybe it scrolls the tracks down, maybe it moves the time focus, and when I try to set the playhead almost in the far right of my current focus, instead it just inches both the playhead and the time focus a little farther along. Always a mystery.
(I have two different and interacting tremor disorders, so micro-accuracy of mouse click location is always a problem for me. So a careful description of the new location-action mapping is not the solution; hitting those now-tiny targets is extremely difficult for me.)

The new QT slider look-and feel may be an improvement for some applications; it is a clear regression on a multitrack video editing timeline.

In some scrolled positions, there is simply no way to click a new playhead position on the timeline. One might say “Click on the time-bar on the Preview window”, but first, the granularity is too coarse, and second, what I need to do is click on the silent spot of a clip waveform; that does not show in the Preview time-bar.

As an engineer,I am classing this as a bug, because the loss of functionality, if there is no parameter-changes fix available, calls into question the forward compatibility of the QT library with the Shotcut tool.

This was already reported and fixed for the next version 21.02.

Depending on scrolling, it might select a track, it might set the playhead to that time, and it might send the time focus flying to the middle or the end of the timeline.

We can prevent the content from appearing underneath the scrollbars. The filter parameters area is already like this in the current version:
image

Maybe I can add a thin, subtle dividing line to create like a gutter. I agree with your points; I will try to get that done for the next release. However, we cannot easily create the classic scroll bar look without the rounded bar.

Thank you. Thank you. Thank you. Thank you. Thank you.

While the rounded scroll bar is [redacted] and [redacted] and appeals mainly [redacted][redacted], we can live with it.

It is those location issues…

(That is not finished, you can see an alignment bug. Work in progress.)

1 Like

These are all fixed now for the next version 20.02 including clicking the time bar with a clip under it:

In some scrolled positions, there is simply no way to click a new playhead position on the timeline

Confirmed in beta testing of 21.02.15.