Text:Rich - text background stays white when copying/pasting text from the internet

A few things about Text:Rich which I found strange. Not sure whether these are bugs - I may be missing something.

  1. Copy some text from the internet. I tested with a) sample text from the BBC News site, b) text from a post on this forum and c) text from Wikipedia.

  2. Paste the text into a Text:Rich filter applied to a transparent clip.

  3. Two things I noticed: 1) the font size comes up as zero, 2) the text has a white background.

  4. I increased the font size using the top menu field. Works OK.

  5. However I can’t seem to find a way to make the white text background transparent, or change text colour.

  6. Paste the text into Notepad. Then copy from there and re-paste into Text:Rich. Text appears as expected - ie with a font size and also with a transparent background.

Is this expected behaviour or a bug?

Screenshot :Top text = copied from Wikipedia; Bottom text = pasted into Notepad, copied, pasted into Text:Rich, font colour changed to green.

Windows 10
Version 20.09.13

When you copy text from a web site, you don’t just copy the text, you also copy the style given to the text.

Bellow is an example of some text copied from the BBC site and pasted into the rich text editor. I saved as a html file from the editor’s menu and you can see that each paragraph have style settings (<p style="), including background-color. White in this case (#FFFFFF).

There is no button to change the text background color in the rich text editor, but you can modify other styles like text color, size or justification.

1 Like

What I said above takes care of the white background problem, but I just noticed that if you erase the word Shotcut that is in the window and then paste new unformatted text, the text you paste is very small, and you can’t change the color.

If you select the word Shotcut (but don’t erase it) then paste, the new text replace “Shotcut” and you can edit it normally.

1 Like

I saw the same yesterday pasting in text from a Word document.
There was no way to clear this unwanted formatting.
Copying from a simple text editor was fine.

Perhaps we need a clear formatting or paste plain text option.

1 Like

Thank you. I suspected that this might be the case but didn’t really know much about it. After Googling the subject just now I find that you are right, copying and pasting text from Chrome etc copies the HTML formatting as well. You live and learn!

Further Googling (other search engines are available … :rofl: :rofl:) led me to this page:

which I found useful. I’m going to look into the “PURE TEXT” program for Windows.

I also read that you can paste text without formatting by pressing CTRL/SHIFT/V, but tried it briefly in Text:Rich, but it doesn’t seem to work - nothing seems to be pasted.

Or maybe a text field just as in Text:Simple?

I’m getting that too. This is more of a bug than the “bug” (which isn’t a bug) in my first post…! :upside_down_face:

1 Like

@jonray - just posted this as a suggestion. The right click menu looks like a good place to have a paste plain text option.

(The WYSIWYG editors on websites usually have a paste plain text button for this same reason).

1 Like


It is a default behavior of this text component from our GUI library. I think this is a case of one person’s bug is another person’s feature. Unfortunately, we do not have control over the low level paste function, and I will need to look into adding a paste plain text function:



1 Like

I added to the rich text editor menu item Paste and Match Style for the next version 20.10. That wording is a macOS convention, and I think it is relatable. Paste Unformatted could be an alternative as that is the typical option in the Windows Paste Special dialog.

Yes, it becomes small but one can change it as well as the size, at least I can. It can be helpful to Select All and then increase the size and color. I believe this is out of my control, and the behavior can change with the next version’s Qt upgrade.

1 Like

Personally I think “Paste Unformatted” or “Paste as Plain Text” would be a better description for most users than “Paste and Match Style” (which to me is quite a confusing term) but then I’m not a macOS user so I’m not used to that term. Just my opinion.

@shotcut - Could there be a keyboard shortcut of Ctrl/Shift/V for “paste Unformatted” please?

En tant qu’utilisateur Mac OS, la fonction “Coller et appliquer le style actuel” veut bien dire ce qu’elle fait réellement. Si le texte précédent est au format “Helvética 24 pt, gras, italique, couleur rouge” le texte collé adoptera ce format.
Si le texte collé par Shotcut ne reprend pas ce format et colle le texte brut (c’est à dire qu’il faut ensuite ré-appliquer le style “Helvética 24 pt, gras, italique, couleur rouge” à ce texte, alors “Coller le texte brut” est plus adapté.

As a Mac OS user, the “Paste and Match Style” feature means what it exactly does. If the previous text is in “Helvetica 24 pt, bold, italic, red color” format, the pasted text will adopt this format.
If the text pasted by Shotcut does not use this format and pastes the raw text (i.e. it is then necessary to reapply the style “Helvética 24 pt, bold, italic, red color” to this text, then “Paste Unformatted” is more suitable.

1 Like

Hi @namna, thank you for the information!

I like Paste Unformatted better.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.