Super-view like option?

is there any equivalent to this?
Scale:
Uncheck Lock X/Y
X Size: 1.33
Y Size: 1.0
Edges: Duplicate
Filter Mode: Linear

I found Distort, I can set Amplitude to 33%
and set Freq & Veloc to 0%, but i don’t think it’s quite the same. (Maybe yes/Maybe no)

Maybe a plugin can be made to simulate a GoPro super view but cautionary on copyright.

Kdenlive has an effect that might do what you want.

https://userbase.kde.org/Kdenlive/Manual/Effects/Distort/Defish

http://stariocek.asuscomm.com/defish-gopro4-black-in-kdenlive.html

https://www.mltframework.org/plugins/FilterFrei0r-defish0r/

This plugin is available in Shotcut’s library. Needs a UI to access it.

1 Like

This old post has Shotcut add-on files to use defish0r. I will likely include some more filters in version 19.09 (not 19.08 due tomorrow).

I am not certain this will provide what the poster wants. Here is a video about SuperView:

The Shotcut engine filter for that is elastic_scale.

@sauron made a Shotcut add-on filter UI for that in his Google Drive. However, that will not work as intended straight out-of-the-box in Shotcut without an additional (included) filter: Size and Position. You need to add that filter, and change Size mode to Distort to make it fill the frame. I should also mention that you should set your Video Mode so the output aspect ratio is set independent of the video you are filtering. At this point, without changing anything in Elastic Scale, Size and Position Distort will stretch the image linearly to fill the frame. Now, you can go into Elastic Scale and increase Non-Linear scale factor to somewhere around 70%. Very cool! And you do need the complicated and expensive Nuke.

1 Like

All posts are good stuff to follow. Now i have tried to use https://www.shotcut.org/notes/make-plugins/ to create ~/.local/share/Meltytech/Shotcut/qml/filters/ and install .qml files, but they do not show in Shotcut. i tried moving the /qml/ folder around to various locations, but nothing works. I also copied the entire “User Contributed” structure to make sure i did it right (i am doing it wrong). i also tried /.local/share/Meltytech/Shotcut/share and various subfolders.
Please tell me the correct folder structure, thank you.

You need to copy the folder containing the meta.qml and ui.qml files to
\Shotcut\share\shotcut\qml\filters

image

Then restart Shotcut, the filters should be available.
In the filter search box type in the filter name, it should show up.

image

Linux & Shotcut-190805.glibc2.14-x86_64.AppImage

~/.local/share/Meltytech/Shotcut/share/shotcut/qml/filters $ ls -lh
total 108K
drwxr-xr-x 2 user user 4.0K Aug 16 12:32 '00 3 level threshold'
drwxr-xr-x 2 user user 4.0K Aug 16 12:32 '00 JRtransition'
[...]
drwxr-xr-x 2 user user 4.0K Aug 16 13:03 '00 elastic scale'
[...]
drwxr-xr-x 2 user user 4.0K Aug 16 12:33  defishOr
drwxr-xr-x 2 user user 4.0K Aug 16 12:32  webvfx_sniper_scope

~/.local/share/Meltytech/Shotcut/share/shotcut/qml/filters $ ls -lh defishOr/
total 12K
-rw-r--r-- 1 user user  902 Aug 16 10:43 meta.qml
-rw-r--r-- 1 user user 7.2K Aug 16 11:10 ui.qml

Also tried ~/.local/share/Meltytech/Shotcut/qml/filters
Also tried ~/Shotcut/share/shotcut/qml/filters which would not make sense, but tried anyway

2019-08-16_12-41
none of the user-contrib show up :frowning:

i “think” i know whats wrong,… it’s looking inside the AppImage compressed file. i would have to --appimage-extract and put them in this extracted structure. ;( i will now research how to create a AppImage to recompress afterward. eesh.

edit: CONFIRMED.

I have the plugins usable in totality (as recompiled AppImage), thanks all.
Now to work on the effects :wink:

Edit: worked very good! @shotcut

Or, just use the portable archive.