Succeded into compiling and installing MLT and shotcut to "$HOME/.local". But

I was trying to compile and install shotcut to “$HOME/.local”. I use Debian.

=== MLT ===

The first problem I encountered, was that an MLT version newer then the official Debian repo has available. Then, I realized I would have to compile and install MLT to “$HOME/.local”.

In order to compile and install MLT, I checked it out from the Git repo. And followed the instructions. I had to install lots of development libraries. I did so until I got rid of all “No package xxx” messages.

This is the output of cmake .:

– The following features have been enabled:

  • GPLv2
  • GPLv3
  • Module: avformat
  • Module: DeckLink
  • Module: Frei0r
  • Module: GDK
  • Module: JACKRack
  • Module: Kdenlive
  • Module: Normalize
  • Module: Oldfilm
  • Module: Movit
  • Module: Plus
  • Module: PlusGPL
  • Module: Qt
  • Module: Resample
  • Module: RtAudio
  • Module: Rubberband
  • Module: SDL1
  • Module: SDL2
  • Module: SoX
  • Module: vid.stab
  • Module: Vorbis
  • Module: XINE
  • Module: XML

– The following OPTIONAL packages have been found:

  • JACK
  • OpenGL
  • Freetype
  • Fontconfig
  • Qt5Core
  • Qt5Gui
  • Qt5Xml
  • Qt5Svg
  • Qt5Widgets
  • Qt5
  • SWIG

– The following REQUIRED packages have been found:

  • Threads
  • PkgConfig
  • X11

– The following features have been disabled:

  • Tests
  • Doxygen
  • Module: NDI
  • Module: OpenCV
  • SWIG: C#
  • SWIG: Java
  • SWIG: Lua
  • SWIG: Node.js
  • SWIG: Perl
  • SWIG: Python
  • SWIG: Ruby
  • SWIG: Tcl

– Configuring done
– Generating done
– Build files have been written to: /home/andre/repositorios/mlt

The only concern I have is SWIG: Python not being enabled.

Then, I compiled and installed it to $HOME/.local. I don’t remember the arguments I passed to cmake to have it installed to this local directory.

=== Shotcut ===

The hard part was figuring out how qmake works. :frowning:

I ended up with this:

qmake -d “PREFIX=$HOME/.local/” “QMAKE_CFLAGS += -I $HOME/.local/include/mlt-7 -I $HOME/.local/include/mlt-7/mlt++” “QMAKE_CXXFLAGS += -I $HOME/.local/include/mlt-7 -I $HOME/.local/include/mlt-7/mlt++” “QMAKE_LFLAGS += -L $HOME/.local/lib”

When I set up “include paths” the way I find “proper”, qmake gives lowest precedence to it :slight_smile: . For that reason, I used things like QMAKE_CXXFLAGS.

Also, make install does not work in the root directory, because the Makefile target install_qmfiles generated byqmake does not respect the variable PREFIX.

So, to install it, I just went to src/ and typed

$ make install

And IT WORKED!!! :sweat_smile:

=== Executing it ===

To execute it, I used

LD_LIBRARY_PATH="$HOME/.local/lib" “$HOME/.local/bin/shotcut”

And IT WORKED!!! :sweat_smile:

=== BUT… :frowning: ===

Nothing appears on the timeline. :frowning:
Not even the buttons. Only the word Timeline and an empty widget. No buttons, no context menu… :frowning:
The other widgets seem okay, though.

When I drag a clip from the playlist to the timeline, the console shows

[Debug ] TimelineDock::dragEnterEvent true

However, the mouse pointer becomes :no_entry_sign:, and I cannot drop it. When I open an MLT file which already has things on the timeline, nothing appears on the timeline.

$ git pull
Already up to date.

What could it be? Any thoughts? :slight_smile:

I have checked out git has 9e4ae4ba533b2a1be2255c47bc61e749cb715ccd, and the problem persisted. Then, I checked out 77521f4c9e28b34cf52aa200295595b9c1d3b298, and the problem disappeared!

So, I guess it is a bug somewhere in between. I will check later.

It was this big commit here:

But I guess people are already working on it. Maybe I am not supposed to branch from HEAD…

No HEAD is fine and current; you need to run qmake again.

I imagined HEAD should be fine. You would have noticed! :slight_smile:

Re running qmake does not do the job. I did uninstall and distclean.

Maybe, my Qt libraries are “old”. That’s okay. I will just keep working on the old version and hope it magically starts working in a few days. :smiley:

Sorry for bothering you with this!

That particular commit added a dependency on QtQuick.Shapes. Maybe you are missing that. For hints, Look for QML error messages in your console log when you run Shotcut.

This topic was automatically closed after 90 days. New replies are no longer allowed.