Stop clip selection

What is your operating system?

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
22.09.23 (same in 22.12.04)

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

First of all, many thanks to the hard-working developers for the excellent project!

I did the following:

  1. only one picture (or clip?) inserted into the timeline
  2. applied a text filter (Rich or Simple) to this clip
  3. split the clip
  4. press “Undo” button

The two parts are now rejoined. Now this clip can no longer be selected so easily!
You can e.g. click on “Source” or the track header and then seclect the clip!

I haven’t checked if this also occurs when there are multiple clips in the timeline. But sometimes I had the impression that such problems also occurred there.

Strange. I can’t reproduce this on version 22.10.25, on Windows 11. I tried your sequence 10 times and each time I had no problem selecting the “un-split” clip.

Thank you for your test!

Unfortunately, I also can no longer reproduce the error!
Before I reported the bug, I tried the process several times. I was able to reproduce this one over and over again! After reboot the PC, it works for me.

Consider the problem solved!