Square output video

Would someone please explain this to me as I seem to be missing why, repeatedly :slight_smile:

When I export projects, the files I receive have 1920x1080 in their “header” or whatever you call that ( to the non programmers reading ). They remain, however, very much square. Not 16x9, 1x1. Except when I just do conversions from the playlist with the same settings.

What’s wrong?

Still puzzles me. Tried doing a whole new project, just cutting the start and end of a video file, adding a stillshot before and after, a music track, and a few filters for text and contrast and such. Still always square. And the color grading is totally messed up but I’m used to that by now.

Here’s some things I’ve tried:

  • All acceptable combinations of settings I could think of when exporting. Preset, filename ext, parallel processing, quality of the codec, audio bitrate, …
  • I tried looking at the mlt to sanity check that, and it did look weird on the aspect but I had no clue how it was supposed to look:

    Besides I input 16 and 9 in the fields and that’s the same in the tutorials.
  • I triple checked all files and images had the right resolution.
  • I made a custom video mode although the one I needed already existed.
  • I did some automatic test I cannot even repeat and still don’t know what that was.
  • I opened the file inside Shotcut again. Still square, Dark gray borders had turned black though.
  • I even used a lifeline and phoned someone.

I feel I’ve been looking at percentage feedback of rectangles turning into squares all that, and that I need a break or two. Hopefully someone can help.

On an other topic, someone told that putting the Locale to Eng, then reboot and load the program // export.
It was OK after that.

Can you try?

Blimey! That actually did the trick :astonished:

This is before:

And here’s after (almost the same proj):

Wuhu! I can actually make videos now :smiley:
As you can see the clip isn’t super well made or anything but now it’s apparent what’s on it! And I can take it from there. You may also note I have quite a few projects I want to complete.
I’ll try some stuff and see if that works as well. But the Windows locale was it. Guess I’m an American now, huh? I have a few issues with some filters not getting saved in the projects, brightness for instance. Color grading will often destroy my projects still and do “repairs” when I open them next time. But this is minor in comparison.
I’ll add to this thread if I encounter anything, but hopefully this was it.
Thank you so much for that!

Looks like something you need to report as a bug here: https://github.com/mltframework/shotcut/issues