Speed up makes clip blank (Shotcut Version 19.08.16)

When ever I speed up a clip, by any amount, the clip loses all audio and video. But when I go back to 1x it is fine again. I don’t understand, I saw a previous topic that mentioned to convert to edit-friendly but I already did that.
Picture of what happens:

Resolution and frame rate are missing in your Properties. That is strange. Maybe you are using Linux and an unsupported build or running the portable archive build wrong.

As soon as I set it back to 1x it gets those properties back. And yes. I am using Ubuntu 18.04

I am not reproducing it on Windows. What is your OS?
If Linux (I see your window manager decorations in the title bar of your screenshot), where did you get Shotcut, and how are you running it?

What does your Timeline Properties show?
Click on Master, then on Properties.
2019-09-09_17-51-30

Ubuntu 18.04. I used the the download link on the Shotcut site from GitHub. running it as an app image

This is the timeline properties. timelineProperties

I tried to reproduce in Ubuntu 18.04 with AppImage v19.08.16 but I could not.

Do you see GPU Effects in Settings?

Just under the settings tab? No, I don’t see it.

I reproduced it. Remove the colons in the file name.

Oh, didn’t expect that! Thanks! Yeah, works now.

This bug is fixed for the next version 19.09.