Sound output ignoring system setting

Hi,

on ubuntu 19.10 with Shotcut version 19.12.31 the following problem happens.
When a clip is played the audio goes to the speakers on my laptop only.
When a headset is plugged in, or sound is switched to hdmi speakers and all other apps play the audio to there, shotcut does not care and still plays over the speakers.
There is no setting where shotcut directs the audio output to.
How can this be fixed?

EDIT:
I kinda found it…
In Settings it says use JACK audio. And this is what has to be done:
install JackEQ from the ubuntu software center.
start jack_server_controller
start jackeq
In the jackeq gui under the port-> menu-> out, set master output to system or audioadapter
go to shotcut and set use JACK in the settings menu
go back to jackeq and under port-> in-> c.1-in-L, there shall be a shotcut:player:out wich can be selected.
Now shoutcut is connected to a JACK port input and the system sound output is connected to JACK port output. Then when payback is started in shotcut the volume indicator bars shall move in jackeq and it should actualy come out of the sound device set.
It seems to have slowed down shotcut substantially though and it is makes gnarly noises on start and stop and seems to be hanging for half a sec.

This is due to the complicated nature of audio on Linux. Most systems use PulseAudio but others not. Unless you enabled JACK in Shotcut’s Settings menu, Shotcut uses the SDL2 library, which has different adapters for PulseAudio, ALSA, etc. If you are using PulseAudio, then you use the controls in your desktop environment to affect audio in the apps - not directly in the app. If you are unsure where to go, you can always install pavucontrol and run it. l You provide very little information for anyone to help you.

Sometimes, with SDL, it does not detect a change in the default audio output while Shotcut is running and you need to restart. This may depend on your version of SDL2, which depends on how Shotcut was installed. On my system with Ubuntu 19.10 it works to plug in headphones in the middle of Shotcut playback because it then outputs to both eternal audio through SPDIF and headphones even though they are separate outputs in PulseAudio.