Size, Position & Rotate filter trouble with circles

I think this is a bug, but I’m not entirely sure. Maybe I don’t understand something about what I’m doing with the Size, Position & Rotate filter.

I have a one-minute video here, created last night.

First, I overlaid a video of me talking over the main video and cropped the overlay with a rectangular-crop filter. I rounded the corners to make it a circle.

After that, I added the Size, Position & Rotate filter in order to resize and move my overlay video. As soon as I added the filter, the shape changed from a perfect circle to the oblong and off-center one you see in my finished video. Try as I might, I could not get back the circle and the centering when the S-P-R filter was being used.

I’m using the current stable release of Shotcut on Windows 11 with a fast reasonably new system.

What do I need to do to get my circle and centered image of my face back?


Hi @spamless

The only way I get this shape is if I change the parameters in the Crop filter.

Changing the values in the SP&R filter will not result in the same shape.

Yes, exactly, and I followed your recent tutorial to create this. (Thanks again!) This is the second video I’ve made with the overlay technique. The first was near-square rectangular, though. I didn’t have this trouble with that video.

Here, as before, I set the shape and centering in the crop filter. It looked similar to your example. But as soon as I enabled the SP&R filter, the shape distorted from a circle and the centering was lost.

Here, I can remove the SP&R filter and put a new one in to show you:


I see what you mean.

I’m surprised to see that when you add the SP&R filter, it doesn’t automatically adapt to the size of the the video in the preview panel. Your rectangle is kind of square, while mine fits in the entire preview.

I assume your project size is 1920x1080. The SP&R filter, should also use these sizes…

That’s the nominal size of my video, yes. The SP&R filter doesn’t default to those sizes, though. And changing it doesn’t resolve the issue.

Sure seems like a bug to me.

I have a question about the crop-filter part of the overlay. There is a circle-crop filter as well. I can create the same circle with that. Why are we starting with a rectangle-crop filter? But anyway, that doesn’t help with my problem here. The crop filter does not seem to be responsible for the issue.


The Crop: Circle filter doesn’t have the Position parameters like the Crop: Rectangle filter has.
Thus the circle is always on the center of the screen. You can make it the size you want, but you can’t move it to be exactly where you want (on the face of the subject for example).

1 Like

It looks like a bug. But if it is, I doubt it is a Shotcut bug since I don’t get the same problem.
There must be another reason for this behavior. But I don’t know what it could be.

Just to be sure, by current stable version you do mean 22.06.23 ?

1 Like

Yes. Shotcut version 22.06.23. Windows 11 Pro is an Insider Preview version, though.


Well, I hope someone else can find a reason for this.

Another question though, can you reproduce this on another project?
Shut down Shotcut, restart your computer and try to apply these filters again on a new project.

I have not reproduced it either, but you can also try changing the order of the filters to overcome the oblong shape. You will need to adjust the values of things after changing their order.

1 Like

Your Video Mode appears to be 1920x1080 (16:9 Aspect ratio).
The image you applied 2 crop filters to has a different aspect ratio, as indicated by the SP&R filter showing a max resolution with a 1080px height (which Shotcut scaled automatically to fill to the Video Mode.

I can duplicate your issue, but it’s a matter of placing SP&R at the top, then your crop filters.


AH! of course, this makes sens. Good find @Hudson555x :+1:

But the problem is, to make this effect works, you can’t play with the filters order.

@spamless What you will need to do is convert your talking head clip to the same ratio as your project. In this case 16:9 (1920x1080)

  • Open a new session of Shotcut
  • Make sure the video mode is set to 1920 x 1080
  • Drag your talking head video in the Source panel. No need to create a track on the timeline.
  • Export as a new video file.

You’ll end up with the same clip, but with the right ratio and black bars on the sides. Those bars don’t matter since you will crop them when you’ll overlay the clip in your main project.

1 Like

Thanks very much to you both, @Hudson555x and @MusicalBox!

Yes, that does work, and I didn’t need to create a new video for the overlay head. I don’t quite yet grok your explanation for why I might need to do this, MusicalBox.

Here it is fixed, at least in one section of my video that has multiple cuts. Next time, if I have this issue I’ll do it this way.


Si l’image d’origine n’a pas exactement le même ratio que le projet elle sera donc déformée par tout filtre ‘Taille, Position & Rotation’ qui sera placé derrière.

Si vous souhaitez redimensionner ou déplacer cette image recadrée, 2 solutions:

  • Placez le filtre ‘Taille, Position & Rotation’ en premier et ensuite mettez le filtre ‘Recadrer: Rectangle’. Après avoir réglé la position et les dimensions du recadrage, revenez sur ‘Taille, Position & Rotation’ pour ajuster l’image dans le cadre.

  • Utilisez le filtre ‘Recadrer: Source’ qui permet un redimensionnement sans déformation.

If the original image does not have exactly the same ratio as the project it will be distorted by any ‘Size, Position & Rotation’ filter that is placed behind it.

If you want to resize or move this cropped image, there are 2 solutions:

  • Put the ‘Size, Position & Rotation’ filter first and then put the ‘Crop: Rectangle’ filter. After setting the position and dimensions of the crop, go back to ‘Size, Position & Rotation’ to adjust the image in the frame.

  • Use the ‘Crop: Source’ filter which allows resizing without distortion.


This topic was automatically closed after 90 days. New replies are no longer allowed.