Shotcut, very cool, few bugs, some ideas

Played around a little with shotcut - Very nice looking!

Few bugs but I’m sure it’s just the stage it’s in. It was a few days ago I downloaded it.

One odd thing, let’s say you overlap a couple of clips on the timeline, and it automatically does crossfade – real super nice - but let’s say later you decide you want to make the cross fade a little more or a little less overlap, you can’t just re-drag the clip because the crossfade becomes its own clip, so you have to delete it, then re-adjust the in-point and/or outpoints on the two clips, and reapply.

Since mlt supports crossfades on the fly, that could dynamic allowing adjustments any time.

Might also be handly to be able to select all clips to right of currently selected clip, to make it easy to move everything when adjusting an overlap.

Other odd bugs:

If I load a single file to my playlist, it doesn’t show up. It just says “Double-click a playlist item to open it in the player…” (And the other lines about that, as if there were nothing added.) However I can play it and add it to my timeline. If I load two or more files at once then they all show in the playlist.

Also, if I drag a clip to my time line, split it at current playhead, then drag the right half to form a cross fade, then press control Z to undo all the way back it segfaults when I undo a couple steps back, but I think before I reach an empty timeline.

(Or instead of splitting at playhead, I can just drag two clips into the timeline and it has the same outcome)

Another oddity is when I have two clips on the same track in the timeline but not butted up, and I want to do a cross fade, it won’t let me do it in a single move: I have to first drag them to touch, let go of the mouse, then I can click and drag again to add the cross fade.

Anyway all in all I am very impressed! It supports all the basic essentials needed for taking raw footage and getting just what you want where you want and presenting it smoothly.

It’s very pleasant to use and real nice.



1 Like

Glad you enjoy the program. :slight_smile:
However I cannot reproduce the issues you describe. For the playlist issue, are you sure you are loading you first clip into the playlist and not just the source player? And for your undo issue, are there any other conditions or steps you take besides adding the clips to the timeline and making the cross fade?

I assume you are using the latest version but in case you aren’t try it again with an update.

Thank you for the response!

For the playlist issue, I do not know where I am loading anything, just that if I click the “Open File” button (top left) and if I select a single item, it opens it in the player and not the playlist, but if I select two or more files, then it loads them both into the play list.

Maybe it’s the intention to be able to play a file without it showing up in play list - seems odd, there’s this file playing but no handle on it. But maybe that’s by design. I kind of imagined all the source files would be in the playlist, but maybe if only one is loaded it is not added but just played.

As to the undo issue, today I clicked the “Check for updates” button or whatever it was, and it said “You are running the latest” or wahtever.

However, I should point out that because the prepackaged download did not include the xkbcommon libs or whatever, I copied them in from my brand newly downloaded and compiled xkbcommon library, so maybe something changed in that. If I had the same xkbcommon libs you had I might not have the crash issue.

I also installed the very latest stable JACK and QT in order to get it working.

I am on slackware 14.2 64 with multilib set up, if that helps any. Kind of an odd platform for video editing I know but it sure is stable, thank the Lord.

It’s no big deal - I can just use melt and my recursive helper script smelt for a lot of my video editing needs. I just wanted to check out shotcut and see what it was like. I’ll check it out again in a few months, see how it goes.

Thanks & have a great day,


That is exactly the intention. Some users do not want a playlist or timeline; they are only at the level of working on one clip at a time to trim and filter it. Advanced users want a way to preview/audition clips on their filesystem to find something without actually adding it to the project.

This is by design. The Source player can only show one thing at a time, but you opened more than one. It needs some place to put them, and you made it clear with multi-selection that you are not making a clip-only project.

Shotcut comes with its own copy/build of Qt. Make sure you use the launch script and do not directly run the shotcut binary in bin/. That is stated on the downloads page.

You can drag the left and right edges of a transition to adjust its timing as long as there is more available footage.

We do not support multi-selection at this time. That opens up a huge can of worms.

This is a known shortcoming due to the maturity of the tool and available time/help. Need to leave some things for new contributors to work on. Can’t just be feature complete, awesome, and bug-free by pressing some easy button. :slight_smile:

All completely understandable. I certainly know that projects take a long time and a lot of work. I been working on my open source cad project for about 12 years, and it’s still not done. So you’ve really done great with shotcut! It’s very nice, reminds me of kinodv but even better!

As to my segfaults, I certainly am using the launcher sh script named shotcut to launch it.

However, it would not run, complaining of:
This application failed to start because it could not find or load the Qt platform plugin “xcb” in “”.

So I had to install QT, and then run
export LD_LIBRARY_PATH=/usr/lib:/usr/lib64

then shotcut runs, but may be using something from my version of QT that must have have been included in the package.

But I haven’t tried the new package in the last few days so it could have been updated recently and I haven’t found out yet.

Anyway, no worries for me. I really really love melt :smiley: so I’m all set, and even made myself a little perl wrapper that remaps melt:xxxxx command line syntax to work with text .melt files recursively. (i.e melt:filename reads filename, and that file contains more melt command line parameters, which includes melt:filename statements, which read another plain text melt file, up to 1022 layers deep.)

but if there’s any tests I can do to help figure out the cause of segfault on my system shotcut, just let me know!

Thanks again for everything,


Yes, the new version does improve Linux binary compatibility a lot. Please give it a try.