Shotcut version 19.10.20 Setting automatic to new crop

Video place into playlist then put on time line then went to filters then went to crop source then cropped time line video left and right then went to settings top left then to video mode then to automatic click auto metic (now here’s the problem where in Shotcut 18,12.23 when clicking automatic the video would auto fill reformat to new cropped size where on export video would export with no border BUT in shotcut 19.10.12 when exact same procedure is done video does not readjust to new cropped size ergo exported video will have borders where it was cropped which did not occur in shotcut 18.12.23. Love the new features but this format adjustment isn’t working as it did in older version …Thanks for your time

In the older version after I cropped a video Id just go to settings video mode click automatic and video would resize to whatever the new crop size was on the time line so say I had a 1080 by 720 original but then cropped it to say 518 by 308 - in the older version Id just goto settings video mode auto metic and presto the new size would show in the playback screen and would then export to proper size as was cropped ergo with out any borders which is what is happening now?

Changing the Video Mode of an open project may change the resolution, but Shotcut does not automatically scale all size and position information. In versions prior to 19.10 changing the video mode where the frame rate changes was very broken. This was fixed in version 19.10.

You are correct, and I am not going to change it. You should set your video mode before you start a project - not in the middle! You are doing it wrong otherwise. That is why the New Project panel has you select a video mode.

Yes I always set format prior to creating videos, but the exception occurs when I have just a short clip and want to crop out the sides (for example) that automatic feature would then create a clip without the borders , saving additional editing to eliminate the border for odd sized clips where the odd size didn’t matter, but oh well. Thanks for your time

To achieve that, use the Crop: Source filter and click the Center checkbox.