Shotcut takes a while to play next clip in timeline

my shotcut workflow

  • open shotcut
  • save a new project file
  • open video file
  • drag video file in playlist
  • drag playlist item to timeline
  • begin using split and playhead tool to delete dead space from video file

dead space refers to parts of the video where there is no audio in recording or I’m caught saying ummmm

  • after most if not dead space has been removed from the track on the timeline
  • i play back the video from the start / beginning of timeline

issue

when playback begins the first clip plays smooth, but that shotcut can take up to several seconds ~< 10 seconds to start playing the next clip in the timeline.

Is this a known issue? or is my hardware? OS? or something that has creeped into recent versions of shotcut?

Specs

  • macOS 10.13.6 all patches applied
  • box - MacBook Pro 2013 late model with Nvidia graphics gard 750M
  • 16GB ram
  • 2.3 i7 processor
  • shotcut v19.10.20 installed via homebrew on macOS

Since dead space is being removed from a single video file, this gets implemented as a Seek operation into the video file to jump to the next segment after the dead space. It sounds like your input file is not very seek-friendly. Is it a 4K H.264 or H.265 file with a long GOP? If so, the delay is due to the seek operation and it is the intrinsic nature of long GOP video. This can be avoided by using the Convert to Edit Friendly feature.

Austin,

Thanks for the input. :pray: The source file is from a OBS recording, I believe it is h264 and not sure about the GOP. The original video file is

  • h264
  • 1920x1080
  • size 146.879 MB

As for GOP, TBH, I don’t even know what GOP means? or does?

The input video is definitely long GOP then. I would guess it is 60 frames per second as well. Try the Convert to Edit Friendly function and see if the new file seeks any better. Convert can be found on the Properties tab in the hamburger menu.

GOP refers to how many frames are delta-compressed before the next full keyframe appears in the stream. The longer the GOP (the greater the distance between full-picture keyframes), the better the file size compression is at the expense of being less seek-friendly. More info:

Your problem is unrelated to the playlist. There is essentially no relationship between playlist and timeline, and you could have skipped the step “drag video file in playlist” and instead dragged from Source player to Timeline. What @Austin mentions is correct; it is due to your video encoding. If you noticed a change in recent version you are correct. From the v19.08 release post:

Changed Settings > Interpolation > Nearest Neighbor to no longer relax seek accuracy. Instead, seek accuracy is now relaxed only during trick playback (reverse, rewind, fast forward).

This change was made to decouple two things that most users do not expect to be related and to provide a preview and editing experience that is more accurate to give less frustration while locating an exact frame.

I use OBS-recording, too.
What are your settings in OBS, - mp4, flv, - nvenc, fps, a.s.o…?

@DvS

here is a link to my present OBS settings I use primarily for recording YouTube videos. I put a little README.md in there for understanding the contents of the directory. If you notice any hiccups in my OBS settings please let me know, as I’m still experiencing the “stutter” stop before the next clip loads in the timeline using Shotcut, even with I changed Interpolation setting,

Settings > Interpolation > Nearest Neighbor

Sorry, I can’t handle this. I have no ‘windfall’-fruit computer. :wink:

This setting no longer affects seeking. You can export and evaluate that result, or if you want better preview, you can convert it to edit-friendly format. I do not know how to read your raw OBS settings. If you are using hardware encoding, then you are probably getting variable frame rate, which is really incompatible with editing. This is widely known. Shotcut tries to detect that and warn you, but it is possible you ignored this and did not mention it, or you asked Shotcut to never warn you about it some time ago. In the latter case, Properties in Shotcut will still tell you “(variable)” next to the frame rate.

1 Like

this is what i’m seeing, and from the looks it doesn’t appear to be a variable frame rate media file.

Let me emphasize tries. It is not foolproof and only checks up to the first 20 frames. Your very odd frame rate suggests it still could be. You can also try using MediaInfo to check that. Good luck trying to improve things.

1 Like