Shotcut refuses to work

Greetings. I’ve been a user of Shotcut in the past. I made a bunch of youtube videos with it and got very used to it, however as of recent, it no longer works. Whenever i attempt to open Shotcut trough the .exe file, it shows up the initial “loading plugins” screen and then either closes, or opens a white screen named “untitled project” that automatically closes after about 5 seconds. I’ve tried to monitor what happens with the app itself trough the Task Manager and from what i found out, the manager shows that the app stops responding a bunch of times, then it flickers between normal and “paused” and then the app closes entirely and disappears from the task manager. I’ve tried many things described here on the forums or in many youtube videos. When i download the portable zip file, it doesn’t work. If i use an installer, it doesn’t work. When i check the “remove registry files” option during the installation process, it still doesn’t change the outcome. I even tried installing multiple older versions of the software, but with the same problem. I am currently out of ideas. I loved to use Shotcut when it worked and i would love to use it again, because it’s easy to use and it doesn’t have very many limitations, such as watermarks. So if anyone could please help, i would really appreciate it.

My pc specs are:

Operating System: Windows 10 Home 64bit
CPU: AMD A8-7410 APU 2.20 GHz
Graphics: AMD Radeon R5 Graphics
RAM: 8GB of RAM with about 6.67 still availible

In the past problems like this have been solved by updating the driver for your display. See below how to do that:

Thank you for sending this link. I have updated all the drivers that were not up-to-date, including regular non-driver windows updates, however the issue still persists. Is there anything else that might be to blame for Shotcut not working?

Are you running Anti-Virus programs? If so, have you tried turning them off, or whitelisting Shotcut?

Have you whitelisted Shotcut in Windows Defender?

You can try to create a new Windows user and login under that or as guest to see if it works there.