Shotcut plays no files any more

Hi.
I used shotcut for several projects on a Kubuntu 18.04 LTS installation. When I started it today I found that no file is being played any more. Even pictures won’t be displayed. I can import old mp4/mkv-files but they won’t play. The used version is up-to-date and it comes from snap (Shotcut-Version 20.04.12).

When I try to start a file I get:

Consumer use format: HD 1080p 25 fps
Profile: 1280 720 50 1 1
Frame size for active video: 1843200
/dev/sdivideotx0: unable to get the file status: Datei oder Verzeichnis nicht gefunden
/dev/sdivideotx0: unable to get the file status: Datei oder Verzeichnis nicht gefunden
/dev/sdivideotx0: unable to get the file status: Datei oder Verzeichnis nicht gefunden
Datei oder Verzeichnis nicht gefunden

could not open video output destination: /dev/sdivideotx0
[Error  ] <MLT> [consumer sdi] failed to initialize
[Debug  ] <Playlist::AppendCommand::redo>  

and this:
[Debug  ] <TimelineDock::dragEnterEvent> true 
[Debug  ] <Timeline::InsertCommand::redo> trackIndex 0 position 0 
[AVIOContext @ 0x582e0c0] Statistics: 650866 bytes read, 0 seeks
[AVIOContext @ 0x582e880] Statistics: 1016337 bytes read, 1 seeks
[h264 @ 0x6aff440] Reinit context to 1280x720, pix_fmt: yuv420p
[h264 @ 0x57eab80] Reinit context to 1280x720, pix_fmt: yuv420p
[h264 @ 0x57c1480] Reinit context to 1280x720, pix_fmt: yuv420p
[Debug  ] <MLT> [producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2
[AVIOContext @ 0x6d189c0] Statistics: 650866 bytes read, 0 seeks
[Debug  ] <MLT> [mlt_producer avformat-novalidate] "testfile.mp4" checking VFR: pkt.duration 512
[h264 @ 0x6c9ec40] Reinit context to 1280x720, pix_fmt: yuv420p
Consumer use format: HD 1080p 25 fps
Profile: 1280 720 50 1 1
Frame size for active video: 1843200
/dev/sdivideotx0: unable to get the file status: Datei oder Verzeichnis nicht gefunden
/dev/sdivideotx0: unable to get the file status: Datei oder Verzeichnis nicht gefunden
/dev/sdivideotx0: unable to get the file status: Datei oder Verzeichnis nicht gefunden
Datei oder Verzeichnis nicht gefunden

and later on:
[Debug  ] <TimelineDock::setSelection> Changing selection to (QPoint(0,0))  trackIndex -1 isMultitrack false 
[Warning] <> file:///snap/shotcut/64/Shotcut.app/share/shotcut/qml/views/timeline/timeline.qml:317: TypeError: Cannot read property 'height' of undefined
[Warning] <> file:///snap/shotcut/64/Shotcut.app/share/shotcut/qml/views/timeline/timeline.qml:315: TypeError: Cannot read property 'y' of undefined
[Warning] <> file:///snap/shotcut/64/Shotcut.app/share/shotcut/qml/views/timeline/timeline.qml:314: TypeError: Cannot read property 'x' of undefined
[Warning] <> file:///snap/shotcut/64/Shotcut.app/share/shotcut/qml/views/timeline/timeline.qml:313: TypeError: Cannot read property 'y' of undefined

Any ideas what to do? My Kubuntu is a default installation with Kernel 4.15.0-96-generic
Thanks.

Turn off Settings > External Monitor > DVEO Vidport.
In versions previous to 20.02, if you had that turned but it is not available, Shotcut would crash. Now, it fails to display. In either case, you do not appear to have it, and it was turned on somehow.

Thank you. The problem is solved … but I don’t know why this option was activated.

This topic was automatically closed after 90 days. New replies are no longer allowed.