Shotcut OpenGL window not opening in Ubuntu 22.04

What is your operating system?

OS: Ubuntu 22.04
Shotcut Installs: (1) snap (2) tarball

What is your Shotcut version (see Help > About Shotcut)?

24.01.28 for both installs

Can you repeat the problem? If so, what are the steps?

Start Shotcut, load or create project: the OpenGL window used to display the video does not appear. It happens every single time.

application.log (37.3 KB)

The following references a BlackMagic video capture card. I’m not currently looking at using that feature. Only the standard OpenGL output.

The DeckLink drivers not installed.

Also here is the output of glxinfo clearly showing that OpenGL is available with an nvidia RTX 2060.

glxinfo.txt (59.1 KB)

Just in case, I tried to install Qt6 natively, but that installed version 6.2.4. However, from what I can see, your app. comes with its own set of libraries and the Help » About Qt menu shows 6.4.3.

[Error ] [consumer sdl2_audio] Failed to initialize SDL: Could not connect to PulseAudio

It looks like this is your problem. You can check if it is installed. It would be surprising if it is not installed because PulseAudio is installed by default on Ubuntu and many applications depend on it.

Please be aware that PipeWire has been replacing PulseAudio, but it is API compatible.

I do all my development and most Linux testing on Pop!_OS/Ubuntu 22.04. This is not a general problem in Shotcut and instead to your environment.

In your log

[Debug  ] <OpenGLVideoWidget::initialize> begin 
[Info   ] <OpenGLVideoWidget::initialize> OpenGL vendor "NVIDIA Corporation" 
[Info   ] <OpenGLVideoWidget::initialize> OpenGL renderer "NVIDIA GeForce RTX 2060/PCIe/SSE2" 
[Info   ] <OpenGLVideoWidget::initialize> OpenGL threaded? true 
[Info   ] <OpenGLVideoWidget::initialize> OpenGL ES? false 
[Info   ] <OpenGLVideoWidget::initialize> OpenGL maximum texture size = 32768 
[Info   ] <OpenGLVideoWidget::initialize> OpenGL maximum viewport size = 32768 x 32768 
[Debug  ] <OpenGLVideoWidget::initialize> end 

Shows OpenGL is fine, and the problem is what @brian showed.

Looking around, if pulseaudio works, then the following should have worked:

$ pactl info
Connection failure: Connection refused

But as we can see, I would get an error instead. Probably meaning that either pulseaudio is not running or the connection is down, somehow. (something crashed?)

What I ended up doing since the currently running service was hung is look for the process with ps to find the PID and kill it:

$ ps -ef | grep pulse
alexis      9825    9781  1 Jan27 ?        01:58:23 /usr/bin/pulseaudio --daemonize=no --log-target=journal
alexis      9897    9825  0 Jan27 ?        00:00:00 /usr/libexec/pulse/gsettings-helper
$ kill 9825

Then I was able to restart pulseaudio like so:

$ pulseaudio --start

After that, I was able to see the setup:

$ pactl info
Server String: 127.0.0.1
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: no
Client Index: 4
Tile Size: 65472
User Name: alexis
Host Name: monster
Server Name: pulseaudio
Server Version: 15.99.1
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.analog-stereo
Default Source: alsa_input.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.mono-fallback
Cookie: cf61:546a

Restarting Shotcut finally worked!

Thank you for the pretty fast replies!

1 Like