Shotcut not updating

Knipsel This message pops up everytime I download the new update. I tried skipping it but it just gives me the same message with other files.

EDIT: I fixed it by downloading the 32 bit version (even tough my PC is 64 bit but it works)

Did you try to redownload from the officials links (Github or FossHub)?
Reinstalling over, did you try to unactivate your antivirus?

=> give info on the version number, system info (type, version…)

Does it happen just searching for the last version clicking on the message? If so, just manually download and update.

Can be related to that?

It relates but I am using Windows 10 not Linux

Were are the official links? I have been doing it with the mirror links

All of the official links are listed here:

You probably have a hung shotcut.exe process in Windows, and that will lock its files to prevent them from being changed. First, ensure you have no visible Shotcut running, and then sse the Windows Task Manager to look for additional shotcut.exe and end/kill them.

So for that reboot computer. Reinstall over last version and see if OK !