Shotcut makes shutdown. Possible failure


#1

Doing true peak tests, it happened several times off of SC coinciding with the following operation:
-I remove content from the timeline.
-I eliminate the track (in this case, video track)Drag (from the playlist) the same video clip that I previously removed from the timeline to the timeline for the automatic creation of a video track.
-After a few seconds, Shotcut closes.


This behavior was already happening in previous versions.
I thought it was a specific situation due to a failure of my pc.

Computer equipment and operating system

Reproduced with Shotcut 19.04.30
Windows 10 Home 1809 - 17763.437
Intel Core i5-7400 3GHz
16GB RAM
Graphics card: NVIDIA GeForce GTX 1060 3GB

Video source info

ffprobe output

[streams.stream.0]
index=0
codec_name=h264
codec_long_name=H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
profile=Main
codec_type=video
codec_time_base=1/60
codec_tag_string=avc1
codec_tag=0x31637661
width=1600
height=1200
coded_width=1600
coded_height=1200
has_b_frames=1
sample_aspect_ratio=1:1
display_aspect_ratio=4:3
pix_fmt=yuv420p
level=40
color_range=tv
color_space=bt709
color_transfer=bt709
color_primaries=unknown
chroma_location=left
field_order=unknown
timecode=N/A
refs=1
is_avc=true
nal_length_size=4
id=N/A
r_frame_rate=30/1
avg_frame_rate=30/1
time_base=1/15360
start_pts=0
start_time=0:00:00.000000
duration_ts=723456
duration=0:00:47.100000
bit_rate=7.135865 Mbit/s
max_bit_rate=N/A
bits_per_raw_sample=8
nb_frames=1413
nb_read_frames=N/A
nb_read_packets=N/A
[streams.stream.0.disposition]
default=1
dub=0
original=0
comment=0
lyrics=0
karaoke=0
forced=0
hearing_impaired=0
visual_impaired=0
clean_effects=0
attached_pic=0
timed_thumbnails=0
[streams.stream.0.tags]
language=und
handler_name=VideoHandler
[streams.stream.1]
index=1
codec_name=aac
codec_long_name=AAC (Advanced Audio Coding)
profile=LC
codec_type=audio
codec_time_base=1/48000
codec_tag_string=mp4a
codec_tag=0x6134706d
sample_fmt=fltp
sample_rate=48 KHz
channels=2
channel_layout=stereo
bits_per_sample=0
id=N/A
r_frame_rate=0/0
avg_frame_rate=0/0
time_base=1/48000
start_pts=0
start_time=0:00:00.000000
duration_ts=2260992
duration=0:00:47.104000
bit_rate=348.930000 Kbit/s
max_bit_rate=384 Kbit/s
bits_per_raw_sample=N/A
nb_frames=2209
nb_read_frames=N/A
nb_read_packets=N/A
[streams.stream.1.disposition]
default=1
dub=0
original=0
comment=0
lyrics=0
karaoke=0
forced=0
hearing_impaired=0
visual_impaired=0
clean_effects=0
attached_pic=0
timed_thumbnails=0
[streams.stream.1.tags]
language=und
handler_name=SoundHandler
[format]
filename=F:/ejmil/Videos/01 LUTs test - Original.mp4
nb_streams=2
nb_programs=0
format_name=mov,mp4,m4a,3gp,3g2,mj2
format_long_name=QuickTime / MOV
start_time=0:00:00.000000
duration=0:00:47.126000
size=42.074703 Mibyte
bit_rate=7.489457 Mbit/s
probe_score=100
[format.tags]
major_brand=isom
minor_version=512
compatible_brands=isomiso2avc1mp41
encoder=Lavf58.20.100
Completed successfully in 00:00:00