Shotcut grinds to halt with high CPU usage

What is your operating system?
Windows 11

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
22.04 and 22.05.23

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

I have created a video, here: shotcut CPU usage problem - YouTube

The video shows it sitting on the ‘convert to edit-friendly’ screen prompt that you get after inserting some variable rate footage onto the timeline. I previously recorded as section of the video I was originally editing with Flashback Express, converted it to MP4 and imported it. It prompts to convert to edit-friendly, and I chose ‘best’ quality, but after that Shotcut was extremely slow indeed, painfully so, with very high CPU usage but no disk activity to speak of and still only using a small proportion of the available 16GB. I tried updating from 22.04 to the latest available ready-compiled version, 22.05.23, and even tried resetting the settings in the registry when I installed it. It didn’t make a difference. Then when I added the extra section of MP4 from Flashback Express that was 22 minutes long, it completely ground to a halt. It took 10 minutes at least for the prompt screen to convert it to an edit-friendly format to come up, and I was not able to actually select a higher quality than the default. A single thread maxxed out again but no disk activity to speak of and still plenty of memory left.

It was as if, even after having converted the previous variable rate footage to an edit-friendly format, it was still demanding a lot of CPU time on it, but it was at least still usable, just. However, when I added the new footage from Flashback Express, that was about 22 minutes, it was just unable to pull itself away from whatever it was doing to do anything else. Just to point out, i’ve got proxy file resolution set to 360p.

Shotcut CPU problem.txt (60.9 KB)

How to sync sound.mlt (27.6 KB)

I hope this information is useful. I’m a bit surprised no-one else has had anything similar. Please let me know if there’s anything I should be checking for.

Mike Hersee

From your video, Shotcut is stuck immediately after showing the Convert dialog and not after you clicked OK or Cancel. You said the dialog appeared when you dragged it from the playlist to the timeline, but usually one gets the dialog when first adding the video to Shotcut - except when dragging files to a non-empty playlist. Please try this: Double-click the playlist item to open it in the Source player. Do you get that convert dialog and does it let you click OK and run the job to convert it? If not, then in Properties choose Convert…

I tried to reproduce it, but I was unable to. My steps:

  1. Open an existing project with populated playlist and timeline.
  2. Drag a known VFR video to the Playlist: no convert dialog appears.
  3. Drag the new playlist item for the VFR video to the Timeline: the convert dialog appears.
  4. Change the quality to best and click OK.
  5. Choose a folder and click Save.
  6. The Jobs panel appears, the job runs to completion with success, the converted clip was added to the playlist, and the timeline clip was replaced with the converted result.
  7. Everything is working normal in Shotcut.

Maybe the problem occurs because your VFR has audio, and Shotcut is having some problem with making a waveform for this clip due to something very particular about the file and how it was written. In my test, I used a clip with audio and made sure that the thumbnail cache item was removed to make Shotcut regenerate it upon dropping to the timeline.

You may well be right about the usual time the prompt to convert the file comes up, I can’t remember exactly. It may be that it took a long time for it to come up. I just started started with a fresh project and tried to import the same file. Immediately it ground to a halt with one CPU maxed out. I’ll do a video later. I’m wondering if it’s the new version of Flashback Express that’s changed the mp4 file format that Shotcut can’t handle in a sensible manner. I’ll do a video after work. Update: the conversion prompt box has STARTED to appear five minutes or so after trying to open that MP4. But all it’s displaying is the box and title with ‘Convert to edit-friendly…(not responding)’, and nothing else is displayed in the box yet. I’ll do a video later.

Ok, after some experiments, I’m beginning to suspect that the culprit is Iolo System Mechanic, the subscription of which ran out a few days ago, and this is the first time I’ve been using Shotcut since then, or any other heavy-processing app. Even though I’ve uninstalled it, everything is running like a dog, despite having a Ryzen 5 3600 with 16GB, and a GTX 750TI - a setup which has been perfetly fine up to now. I’ve tried going back a couple of Nvidia driver releases as well, and Shotcut 22.01, and VS code - all very slow. So the problem appears to be outside Shotcut at the moment.

I suspect that System Mechanic deliberately corrupted something to slow things down in order to encourage me to pay for a new subscription - that it would then magically fix again.

Nope, I don’t think it’s a system issue after all, everything else runs just fine when Shotcut is not running. Openshot also runs just fine with the same videos that Shotcut grinds to a halt with. I’ve tried going back to 22.01 and an earlier version of the Nvidia driver when it was definitely working, but nothing has made a difference. So I am currently suspecting it’s to do with a recent windows 11 update somehow finding an incompatibility with Shotcut in combination with my hardware, or something. I’ve tried using Process Explorer but I can’t really make any sense of what it’s telling me. If someone can interpret the results I can find a way to attach a debug program to Shotcut and produce a dump. Can anyone suggest a way of finding out what the heck Shotcut is doing? here’s a new demo: Shotcut still not working properly - YouTube

Have you tried moving this file to a different location?
C:/Users/Mike Hersee/AppData/Local/Meltytech/Shotcut/autosave/ScreenRecord_2022-05-29-11-35-28 - Converted.mkv


Do other files work fine for you? If it is just one trouble file, maybe you could share the file with us so we can reproduce the problem. For example, if you store the file on Google Drive and then send a link to it.

Well, I’ve just tried that, unsetting ‘use project folder’ and changed it to the default proxy file folder instead. No difference. I’ve just tried to import a file that imported within a couple of seconds to Openshot, and Shotcut just grinds to a halt with (not responding) for a couple of minutes.
Now the ‘convert to edit-friendly’ box empty box has appeared with no contents in it, which is also (not responding)
Now, after a couple of minutes, the contents of the ‘convert to edit-friendly’ have come up, but the timer symbol is on, the window is still (not responding), and the audio of the file I opened is now playing, but not the picture.
Ok, it’s now finished playing the audio of this two minute video having only displayed the first frame of the image in the central window, but the egg-timer symbol is back.
The memory usage has jumped and is creeping up to a huge amount, and it has stimulated a huge amount of disk activity, which it has done before. The whole PC has almost ground to a halt.
Ok, videoed having to cancel Shotcut to get the PC usable again. Disk activity has finally stopped also.

We understand you are having problems with Shotcut. At this point, it’s time to explore the specifics of your project file to the specifications of the original file you’re trying to work with. Other people have to attempt to get the same results to find a solution. I suspect other software might be interfering with file permissions. Have you tried to close out all anti-virus type software and run Shotcut?

Aha! Finally found the culprit! Just so you know, it was all files I tried, including ones that had previously been no problem. But I had noticed recently that the Nvidia game overlay was coming up at the beginning briefly when starting shotcut, as it does when I play Call Of Duty, but after a few seconds I forgot about it and didn’t think it was significant. Why it has started coming up with Shotcut I have no idea because I’ve only got COD set as a game or app within the Nvidia app. But anyway, it occurred to me there might be some problem there so I turned the game overlay off completely and Shotcut has gone back to normal. So that appears to have been the whole problem all along.

Thanks to everyone who tried to help though :slightly_smiling_face: