Shotcut exportiert nur die Audio


#1

Hi,
Ich habe ein Problem Shotcut exportiert nur die Audio und das Bild ist Schwarz als ob es nicht da wäre aber in der Zeitachse spielt sich alles normal ab (Das Format stimmt auch mp4). Heute habe ich dir neuste Version gedownloadet und seitdem ist der Fehler da, kann es daran liegen?
Hatte das Problem davor noch nie habe auch schon ca. 5 Videos geschnitten und exportiert ohne Probleme.
Bitte um Hilfe
Danke im Vorraus


#2

Google translation:

I have a problem Shotcut exports only the audio and the picture is black as if it were not there but in the timeline everything is normal (the format is synonymous mp4). Today I downloaded the latest version and since then the error is there, can it be because of it?
Had the problem before that never synonymous already cut about 5 videos and exported without problems.
Please help
Thanks in advance


#3

I have occasionally had the same problem, intermittently.

I will try to reproduce it again, then I hope I can help with the solution to your problem.


Google translation:
Google Übersetzung:

Ich hatte gelegentlich zeitweise das gleiche Problem.

Ich werde versuchen, es erneut zu reproduzieren, dann hoffe ich, dass ich Ihnen bei der Lösung Ihres Problems helfen kann.


#4

Progress. I found a pair of files, MLT and MP4, when I had the same problem several versions back; whatever version was current in September 2018.

Now I am running an Export in 18.12.23 to see if it reproduces the same problem.

Then I will compare that MLT with the MLT that Exported successfully.

Google Translation:
Google Übersetzung:

Fortschritt. Ich fand ein Paar von Dateien, MLT und MP4, als ich das gleiche Problem mehrere Versionen zurück hatte; welche Version im September 2018 aktuell war.

Jetzt führe ich einen Export in 18.12.23 aus, um zu sehen, ob das gleiche Problem auftritt.

Dann werde ich das MLT mit dem MLT vergleichen, das erfolgreich exportiert wurde.


#5

Preliminary diagnosis - this happens (black screen with audio) when there is a codec mismatch.

I believe the specific fault is using (forcing) the “standard” libx264 codec when hardware encoding is enabled. (Hardware encoding wants a different codec, I think; it defaults to h264_nvenc, which is quite good.)

I am running further tests. Each test export takes more than one hour.

It would be easy for this to happen on the upgrade to the latest version, as the new version defaults to “Use hardware encoder”, so if the older standard libx264 codec, it may be incompatible with Hardware encoding.

(I admit that, as a newbie to Shotcut myself, I am on the thin edge of my competence on this matter.)

I would suggest trying

– Disable (un-check) Hardware encoding if using libx264
—or—
– Use h264_nvenc with Hardware encoding

Google Translation:
Google Übersetzung:

Vorläufige Diagnose - Dies geschieht (schwarzer Bildschirm mit Audio), wenn eine Codec-Abweichung vorliegt.

Ich glaube, dass der spezifische Fehler den “standard” libx264-Codec verwendet (erzwingt), wenn die Hardware-Codierung aktiviert ist. (Hardware-Kodierung möchte einen anderen Codec, denke ich; der Standardwert ist h264_nvenc, was ziemlich gut ist.)

Ich führe weitere Tests durch. Jeder Testexport dauert mehr als eine Stunde.

Dies ist beim Upgrade auf die neueste Version einfach, da die neue Version standardmäßig “Hardware-Encoder verwenden” verwendet. Wenn der ältere libx264-Standardcodec verwendet wird, ist er möglicherweise nicht mit der Hardware-Codierung kompatibel.

(Ich gebe zu, dass ich als Neuling von Shotcut selbst am Rande meiner Kompetenz in dieser Angelegenheit bin.)

Ich würde vorschlagen, es zu versuchen

  • Deaktivieren (Deaktivieren) der Hardware-Kodierung bei Verwendung von libx264
    -oder-
  • Verwenden Sie h264_nvenc mit Hardware-Codierung