Shotcut distorts my audio when exported

Hi, I’ve made 6 videos with Shotcut now, I love how it’s easy to use, and how it has lots of filters and file formats. Though there is one issue with it, for me at least. Every time I export a video it distorts the audio in random places. Some audio crackles and others echo kinda, replaying random .5 second audio sections twice… I’ve tried many things, I switched my display method to Open GL because apparently that is used with AMD which is what I have. And I’ve also closed everything but Shotcut, using the “Youtube” render preset. And it still had the same issues. I also tried different bit-rates and it didn’t help. I noticed the echoing audio that plays twice didn’t happen in the preview. But it happens in the exported versions, and when that happens the video stutters as well. I am confused, would be nice if someone could help me out. Every time I export a video there is either 1 - 7 areas in the video with glitchy audio or video. I exported the same video 4 times now, all of them were glitchy in the same exact spots, and I used different settings.

My computer specs:

  • Radeon RX560
  • FX 6300 6 core
  • 8 GB of ram
  • Using the current version of Shotcut

One cause for this symptom can be source files that are not easy for Shotcut to seek. Variable framerate sources, for example, can be difficult. Can you provide information about the source of your clips?

As an experiment, you can try to use the “Convert to edit friendly” feature in Shotcut. After the source is converted, hopefully Shotcut can work with it better.

1 Like

The clips are from Radeon Relive, which are recorded in 1080p 60fps. There isn’t a problem with the videos, so yeah I’ll try that feature out.

And how do you find the “Convert to edit friendly” feature? Sorry I’m new to this.

Select the hamburger menu in the clip properties

Choose “Convert to Edit-friendly…”

Then follow the on-screen instructions.

Ohhh okay, thanks : )

Okay so, I converted it to the edit friendly version. I checked the edit friendly version and it was perfect with no glitchy stuffs. Though when I exported a part of the edit friendly version, it had the glitches again with audio.

Disappointing. Let’s try some more things…

Can you provide the export settings you are using?

Can you try to export with “Parallel Processing” disabled?

Can you share your video for other people to be able to see the glitching you are describing? For example, you could provide a youtube or streamable link. Or maybe you can upload it to dropbox and share.

If it’s okay, I could link a Youtube video showing what I am experiencing so you can get a better idea of what is happening.

image image image
I’m using the default settings right now, I tried disabling that but there wasn’t a difference.
Here is a video that compares all 3 clips, without parallel processing, with, and the editing friendly version. I had to record the already recorded clips with Relive cuz the editor would bug out and start making the noises on the exported video.

The first clip is the edit friendly one, the person does cut out 2 times but otherwise it’s fine. The second one has some weird echos and cracking same with the last. - https://www.youtube.com/watch?v=bVm7UFqNOr4

Did you intend to use 6 channels (5.1 surround) of audio instead of 2 channel stereo? If not:

  1. load the project
  2. change Settings > Audio Channels to 2,
  3. save (it does not currently consider an audio channels change as a modified document to automatically prompt you)
  4. restart
  5. before loading the project, change Settings > Audio Channels to 2 again to prevent it from using 6 on the start of a new project
  6. load the project
  7. export with parallel processing turned off

Oh forgot to mention, I messed with the channels to. I used 2, and 5.1. It still had the same results so oof.

Are you aware that currently when you Convert to Edit-friendly, Shotcut does not replace the clips in your project with the converted version? You would need to do that manually for now.

Yeah, I took the converted version and put it in a new project.

I watched your video and heard some of the problems you describe. I do not know it is causing it. Could be it due to audio clipping? This is where the levels reach their numeric maximum. Normally, it results in distortion. You can look at the audio meter in Shotcut when playing an area where a problem occurs to see if the bars reach close to 0 or over.
Is the problem occurring in the middle of footage, where you have not made an edit or started or ended a filter or transition?

No, they just occur in random places, (the audio glitches). And I checked the meter in Shotcut and it always stays below -5 when making the glitching sounds.

Are you always playing the exported file in the same player? I see you made the example video by recording your playback using Relive. If you play the exported file in Shotcut do you hear the problem as well? Do you have another player such as VLC?

No, I don’t always play it in the same player. I’ve even uploaded the raw files to Youtube vs the edited ones and the edited ones had the issues. That is when I first ran into the problem and noticed I had staticy sounds. It isn’t just my media players. I get staticy sounds in the preview near the filters though… But it fixes for those areas after I export.

I am running out of ideas, but you should definitely try without hardware encoder enabled.

Tried that, didn’t work.
I’ll try reinstalling the program.