Shotcut crashed my Dell Inspiron 17 7000 series laptop 4 X while exporting a video


#1

I found Shotcut while searching for my fourth video editing software in hopes of finding something that works. I have gone through several programs all promising xy and z but they all have failed miserably.

I have been only able to complete and upload one video using this software. Now it just wants to quit, crashes my computer and I have to start all over again. This is unacceptable while acknowledging that this is a free software.

Is it possible to de bug future software so that it works as indicated it does?

Any help would be appreciated. This is a 15 minute video with both stills and gopro footage. It gets almost done then BAM! my pc quits. The most recent experience was just moments ago when after clicking export, adjusting my settings it no sooner started to export than the entire pc just crashed again.

I have uninstalled the software. Derfagged and retuned my pc. Re installed the software with the same miserable results.

Come on, really?!

Frustrated


#2

There are no guarantees that the software will work flawlessly on all computer systems, there are simply too many variables to consider.
In any case, you could at least post the log file.
https://shotcut.org/FAQ/


#3

According to Dell’s website for your computer it comes with “Up to 512GB” SSD (which you shouldn’t defrag an SSD). What are the file properties from your GoPro footage?

Shotcut has not crashed my computer, yet. :face_with_raised_eyebrow: Tomorrow is a new day. But yes Shotcut has crashed itself, I just restart it, and keep going. I accept it because the results of Shotcut, a free program to you and I, is just simply amazing. And it comes with free technical support right here.:nerd_face:

Generally in tech forums, it’s best to ask for help, present factual information. Never insult. It’s ok to be frustrated. It may help you to edit your post and take out all of the insults, although not required.


#4

There’s a lot of 17 7000 models, which one do you actually have? what version of shotcut, did you turn on gpu processing, what filters ect.


#5

This sounds like a case of the software causing the machine to overheat. Usually, it is a good thing to make the export process go as fast possible and use as much CPU and GPU compute power available as possible. It is actually somewhat difficult to make software max out a system resources to give you the results as fast as possible. This is actually a sign of achievement! However, we do not want the processing, which can run in the background, to prevent usefulness of the computer while is running. On Mac and Linux, we tell it to be “nice”, but that API is not on Windows. Next version includes a Windows API call to make it nice. That will not prevent overheating, however.

What you need to do is turn off options that are designed to maximize your system. In the Export panel, turn off the Parallel processing checkbox on the Video tab, and in Codec tab, set Codec threads to 1. I think it will take quite some work to make the software read temperature sensor data and automatically throttle itself, but I will give it some consideration. Also, I will think about a way to make the performance settings easier to manage.


#6

The machine overheating is a sign of poor design on dell’s part not yours @shotcut We use lenovo laptops at my office and I’ve yet to see one exhibit that kind of overheat behavior exporting a video. That said he could likely limit the cpu frequency to ~80% inside the power settings in windows to still realize a faster export while avoiding the overheating if that’s the case.


#7

I haven’t had any export crashes or overheating on my 6 year old Dell XPS L502x, and that’s with other stuff running in the background as well (backup, Norton, etc.), on a system upgraded to Winodws 10 that doesn’t even officially support it.
If it’s happening with a particular project, you may want to rebuild the project and try again. I have had two project files get corrupted so that exporting and even previewing caused the program (not the whole computer) to crash. Also disable GPU processing. That doesn’t work at all for me (Nvidia GeForce GT 540M 2GB).